From 44d7267cd9bddfe0e5e382db5f1d5a83a832b6ff Mon Sep 17 00:00:00 2001
From: Logan Dethrow <log@lindenlab.com>
Date: Wed, 29 Jun 2011 17:22:39 -0400
Subject: Got indra/test to build.  Fails to run due to missing .so files.

---
 indra/test/CMakeLists.txt | 18 ++++++++----------
 1 file changed, 8 insertions(+), 10 deletions(-)

(limited to 'indra/test/CMakeLists.txt')

diff --git a/indra/test/CMakeLists.txt b/indra/test/CMakeLists.txt
index e9eb3c1884..708ceeac42 100644
--- a/indra/test/CMakeLists.txt
+++ b/indra/test/CMakeLists.txt
@@ -4,7 +4,7 @@ project (test)
 
 include(00-Common)
 include(LLCommon)
-include(LLDatabase)
+#include(LLDatabase)
 include(LLInventory)
 include(LLMath)
 include(LLMessage)
@@ -48,13 +48,11 @@ set(test_SOURCE_FILES
     llscriptresource_tut.cpp
     llsdmessagebuilder_tut.cpp
     llsdmessagereader_tut.cpp
-    llsd_new_tut.cpp
+#    llsd_new_tut.cpp			# Fails [LLSD(new), 4] fail: 'NaN to string: expected 'nan' actual '-nan''
     llsdutil_tut.cpp
     llservicebuilder_tut.cpp
     llstreamtools_tut.cpp
     lltemplatemessagebuilder_tut.cpp
-    lltimestampcache_tut.cpp
-    lltranscode_tut.cpp
     lltut.cpp
     lluuidhashmap_tut.cpp
     message_tut.cpp
@@ -76,11 +74,11 @@ if (NOT WINDOWS)
        )
 endif (NOT WINDOWS)
 
-if (NOT DARWIN)
-  list(APPEND test_SOURCE_FILES
-    lldatabase_tut.cpp
-    )
-endif (NOT DARWIN)
+#if (NOT DARWIN)
+#  list(APPEND test_SOURCE_FILES
+#    lldatabase_tut.cpp
+#    )
+#endif (NOT DARWIN)
 
 set_source_files_properties(${test_HEADER_FILES}
                             PROPERTIES HEADER_FILE_ONLY TRUE)
@@ -100,7 +98,7 @@ target_link_libraries(test
     ${LLCOMMON_LIBRARIES}
     ${EXPAT_LIBRARIES}
     ${GOOGLEMOCK_LIBRARIES}
-    ${APRICONV_LIBRARIES}
+#    ${APRICONV_LIBRARIES}
     ${PTHREAD_LIBRARY}
     ${WINDOWS_LIBRARIES}
     ${BOOST_PROGRAM_OPTIONS_LIBRARY}
-- 
cgit v1.2.3


From 2291d5a9becd3b851f77c0fbdb07969946f1dd02 Mon Sep 17 00:00:00 2001
From: Logan Dethrow <log@lindenlab.com>
Date: Fri, 9 Sep 2011 11:56:47 -0400
Subject: Fixed indra test dynamic library issues.

---
 indra/test/CMakeLists.txt | 15 ++++++++++-----
 1 file changed, 10 insertions(+), 5 deletions(-)

(limited to 'indra/test/CMakeLists.txt')

diff --git a/indra/test/CMakeLists.txt b/indra/test/CMakeLists.txt
index 708ceeac42..86cf153610 100644
--- a/indra/test/CMakeLists.txt
+++ b/indra/test/CMakeLists.txt
@@ -38,7 +38,7 @@ set(test_SOURCE_FILES
     lldoubledispatch_tut.cpp
     llevents_tut.cpp
     llhttpdate_tut.cpp
-    llhttpclient_tut.cpp
+#    llhttpclient_tut.cpp               # Segfaults, disabled.
     llhttpnode_tut.cpp
     lliohttpserver_tut.cpp
     llmessageconfig_tut.cpp
@@ -117,16 +117,21 @@ endif (WINDOWS)
 
 get_target_property(TEST_EXE test LOCATION)
 
-SET_TEST_PATH(LD_LIBRARY_PATH)
-LL_TEST_COMMAND(command "${LD_LIBRARY_PATH}"
-  "${TEST_EXE}" "--output=${CMAKE_CURRENT_BINARY_DIR}/cpp_test_results.txt" "--touch=${CMAKE_CURRENT_BINARY_DIR}/cpp_tests_ok.txt")
+SET_TEST_PATH(DYLD_LIBRARY_PATH)
+
+LL_TEST_COMMAND(command 
+  "${DYLD_LIBRARY_PATH}"
+  "${TEST_EXE}"
+  "--output=${CMAKE_CURRENT_BINARY_DIR}/cpp_test_results.txt" 
+  "--touch=${CMAKE_CURRENT_BINARY_DIR}/cpp_tests_ok.txt")
+
 ADD_CUSTOM_COMMAND(
   OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/cpp_tests_ok.txt
   COMMAND ${command}
   DEPENDS test
   WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
   COMMENT "C++ unit tests"
- )
+  )
 
 set(test_results ${CMAKE_CURRENT_BINARY_DIR}/cpp_tests_ok.txt)
 
-- 
cgit v1.2.3


From 3151b6ce503ffc877589422c5559647d363d5bf1 Mon Sep 17 00:00:00 2001
From: Logan Dethrow <log@lindenlab.com>
Date: Fri, 9 Sep 2011 15:22:11 -0400
Subject: Fixed llhttpclient_tut.cpp by initializing the LLCurl class during
 test setup.

---
 indra/test/CMakeLists.txt | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

(limited to 'indra/test/CMakeLists.txt')

diff --git a/indra/test/CMakeLists.txt b/indra/test/CMakeLists.txt
index 86cf153610..45c6130bd5 100644
--- a/indra/test/CMakeLists.txt
+++ b/indra/test/CMakeLists.txt
@@ -38,7 +38,7 @@ set(test_SOURCE_FILES
     lldoubledispatch_tut.cpp
     llevents_tut.cpp
     llhttpdate_tut.cpp
-#    llhttpclient_tut.cpp               # Segfaults, disabled.
+    llhttpclient_tut.cpp
     llhttpnode_tut.cpp
     lliohttpserver_tut.cpp
     llmessageconfig_tut.cpp
-- 
cgit v1.2.3


From 8a289a161df3e9856f65e09d8828ad8f6d84654f Mon Sep 17 00:00:00 2001
From: Logan Dethrow <log@lindenlab.com>
Date: Fri, 9 Sep 2011 15:52:36 -0400
Subject: Re-enabled and fixed llsd_new_tut.cpp by copying the fixed version
 from the server test directory.

---
 indra/test/CMakeLists.txt | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

(limited to 'indra/test/CMakeLists.txt')

diff --git a/indra/test/CMakeLists.txt b/indra/test/CMakeLists.txt
index 45c6130bd5..003f27ed7a 100644
--- a/indra/test/CMakeLists.txt
+++ b/indra/test/CMakeLists.txt
@@ -48,7 +48,7 @@ set(test_SOURCE_FILES
     llscriptresource_tut.cpp
     llsdmessagebuilder_tut.cpp
     llsdmessagereader_tut.cpp
-#    llsd_new_tut.cpp			# Fails [LLSD(new), 4] fail: 'NaN to string: expected 'nan' actual '-nan''
+    llsd_new_tut.cpp			# Fails [LLSD(new), 4] fail: 'NaN to string: expected 'nan' actual '-nan''
     llsdutil_tut.cpp
     llservicebuilder_tut.cpp
     llstreamtools_tut.cpp
-- 
cgit v1.2.3


From dc58b5207b3ed92dfcf7ecf16c7844453faac18f Mon Sep 17 00:00:00 2001
From: Logan Dethrow <log@lindenlab.com>
Date: Fri, 9 Sep 2011 17:22:37 -0400
Subject: Re-enabled llapp_tut.cpp test for testing. Copied llapp_tut.cpp from
 server directory.

The commented line indicates threading breakage in the LLApp test, but I have not seen evidence of this so far while testing on linux.
---
 indra/test/CMakeLists.txt | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

(limited to 'indra/test/CMakeLists.txt')

diff --git a/indra/test/CMakeLists.txt b/indra/test/CMakeLists.txt
index 003f27ed7a..6f01a1336f 100644
--- a/indra/test/CMakeLists.txt
+++ b/indra/test/CMakeLists.txt
@@ -32,7 +32,7 @@ include_directories(
 
 set(test_SOURCE_FILES
     io.cpp
-#    llapp_tut.cpp                      # Temporarily removed until thread issues can be solved
+    llapp_tut.cpp
     llblowfish_tut.cpp
     llbuffer_tut.cpp
     lldoubledispatch_tut.cpp
@@ -48,7 +48,7 @@ set(test_SOURCE_FILES
     llscriptresource_tut.cpp
     llsdmessagebuilder_tut.cpp
     llsdmessagereader_tut.cpp
-    llsd_new_tut.cpp			# Fails [LLSD(new), 4] fail: 'NaN to string: expected 'nan' actual '-nan''
+    llsd_new_tut.cpp
     llsdutil_tut.cpp
     llservicebuilder_tut.cpp
     llstreamtools_tut.cpp
-- 
cgit v1.2.3


From 15a3df2f084947fb977e87817f786c7aa35d3af7 Mon Sep 17 00:00:00 2001
From: Logan Dethrow <log@lindenlab.com>
Date: Tue, 13 Sep 2011 14:41:00 -0400
Subject: Always build indra/test, run if LL_TESTS is enabled. Removed python
 test run command since there are no python tests in the viewer.

---
 indra/test/CMakeLists.txt | 37 +++++++------------------------------
 1 file changed, 7 insertions(+), 30 deletions(-)

(limited to 'indra/test/CMakeLists.txt')

diff --git a/indra/test/CMakeLists.txt b/indra/test/CMakeLists.txt
index 6f01a1336f..dc37066e52 100644
--- a/indra/test/CMakeLists.txt
+++ b/indra/test/CMakeLists.txt
@@ -4,7 +4,6 @@ project (test)
 
 include(00-Common)
 include(LLCommon)
-#include(LLDatabase)
 include(LLInventory)
 include(LLMath)
 include(LLMessage)
@@ -74,12 +73,6 @@ if (NOT WINDOWS)
        )
 endif (NOT WINDOWS)
 
-#if (NOT DARWIN)
-#  list(APPEND test_SOURCE_FILES
-#    lldatabase_tut.cpp
-#    )
-#endif (NOT DARWIN)
-
 set_source_files_properties(${test_HEADER_FILES}
                             PROPERTIES HEADER_FILE_ONLY TRUE)
 
@@ -98,7 +91,6 @@ target_link_libraries(test
     ${LLCOMMON_LIBRARIES}
     ${EXPAT_LIBRARIES}
     ${GOOGLEMOCK_LIBRARIES}
-#    ${APRICONV_LIBRARIES}
     ${PTHREAD_LIBRARY}
     ${WINDOWS_LIBRARIES}
     ${BOOST_PROGRAM_OPTIONS_LIBRARY}
@@ -135,25 +127,10 @@ ADD_CUSTOM_COMMAND(
 
 set(test_results ${CMAKE_CURRENT_BINARY_DIR}/cpp_tests_ok.txt)
 
-if (EXISTS /etc/debian_version_FAIL)
-  # The Python tests have all kinds of wacky non-portable assumptions
-  # built in.
-
-  add_custom_command(
-    OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/py_tests_ok.txt
-    COMMAND ${PYTHON_EXECUTABLE}
-    ARGS
-      ${CMAKE_CURRENT_SOURCE_DIR}/test.py
-      --mode=static
-      --output=${CMAKE_CURRENT_BINARY_DIR}/py_test_results.txt
-      --touch=${CMAKE_CURRENT_BINARY_DIR}/py_tests_ok.txt
-      --mode=static
-    DEPENDS test.py
-    WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
-    COMMENT "Python unit tests"
-    )
-
-  list(APPEND test_results ${CMAKE_CURRENT_BINARY_DIR}/py_tests_ok.txt)
-endif (EXISTS /etc/debian_version_FAIL)
-    
-add_custom_target(tests_ok ALL DEPENDS ${test_results})
+# This should cause the test executable to be built, but not 
+# run if LL_TESTS is disabled. This will hopefully keep the
+# tests up to date with any code changes changes even if 
+# developers choose to disable LL_TESTS.
+if (LL_TESTS)  
+    add_custom_target(tests_ok ALL DEPENDS ${test_results})
+endif (LL_TESTS)
\ No newline at end of file
-- 
cgit v1.2.3


From ec065bdfda9139197cfc467dc18e65fff32048f8 Mon Sep 17 00:00:00 2001
From: Logan Dethrow <log@lindenlab.com>
Date: Wed, 14 Sep 2011 14:09:50 -0400
Subject: Copied newer version of llevents_tut from server. Fixed line ending
 in CMakeLists.txt.

---
 indra/test/CMakeLists.txt | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

(limited to 'indra/test/CMakeLists.txt')

diff --git a/indra/test/CMakeLists.txt b/indra/test/CMakeLists.txt
index dc37066e52..328ab4ca51 100644
--- a/indra/test/CMakeLists.txt
+++ b/indra/test/CMakeLists.txt
@@ -133,4 +133,4 @@ set(test_results ${CMAKE_CURRENT_BINARY_DIR}/cpp_tests_ok.txt)
 # developers choose to disable LL_TESTS.
 if (LL_TESTS)  
     add_custom_target(tests_ok ALL DEPENDS ${test_results})
-endif (LL_TESTS)
\ No newline at end of file
+endif (LL_TESTS)
-- 
cgit v1.2.3


From 5afffabc1aa9c012c21a4f669da8c0426552e19b Mon Sep 17 00:00:00 2001
From: Logan Dethrow <log@lindenlab.com>
Date: Thu, 15 Sep 2011 14:14:15 -0400
Subject: Backed out changeset 19aa1a773410

---
 indra/test/CMakeLists.txt | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

(limited to 'indra/test/CMakeLists.txt')

diff --git a/indra/test/CMakeLists.txt b/indra/test/CMakeLists.txt
index 328ab4ca51..dc37066e52 100644
--- a/indra/test/CMakeLists.txt
+++ b/indra/test/CMakeLists.txt
@@ -133,4 +133,4 @@ set(test_results ${CMAKE_CURRENT_BINARY_DIR}/cpp_tests_ok.txt)
 # developers choose to disable LL_TESTS.
 if (LL_TESTS)  
     add_custom_target(tests_ok ALL DEPENDS ${test_results})
-endif (LL_TESTS)
+endif (LL_TESTS)
\ No newline at end of file
-- 
cgit v1.2.3


From 85c8c97f7aeb8f0df1c683375aa8108eeaf70201 Mon Sep 17 00:00:00 2001
From: Logan Dethrow <log@lindenlab.com>
Date: Thu, 15 Sep 2011 14:14:55 -0400
Subject: Fixed CMakeLists.txt line ending.

---
 indra/test/CMakeLists.txt | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

(limited to 'indra/test/CMakeLists.txt')

diff --git a/indra/test/CMakeLists.txt b/indra/test/CMakeLists.txt
index dc37066e52..328ab4ca51 100644
--- a/indra/test/CMakeLists.txt
+++ b/indra/test/CMakeLists.txt
@@ -133,4 +133,4 @@ set(test_results ${CMAKE_CURRENT_BINARY_DIR}/cpp_tests_ok.txt)
 # developers choose to disable LL_TESTS.
 if (LL_TESTS)  
     add_custom_target(tests_ok ALL DEPENDS ${test_results})
-endif (LL_TESTS)
\ No newline at end of file
+endif (LL_TESTS)
-- 
cgit v1.2.3