From ff071bbdce6478f8cd666ecf75658ca6e24f1140 Mon Sep 17 00:00:00 2001
From: Monroe Linden <monroe@lindenlab.com>
Date: Tue, 28 Sep 2010 16:49:22 -0700
Subject: Added a mechanism for preventing classes of notifications from being
 displayed, controlled by the notification_visibility.xml file in the viewer
 skin.

Reviewed by Richard.
---
 indra/llui/CMakeLists.txt | 1 +
 1 file changed, 1 insertion(+)

(limited to 'indra/llui/CMakeLists.txt')

diff --git a/indra/llui/CMakeLists.txt b/indra/llui/CMakeLists.txt
index e98201ea63..864f3f699e 100644
--- a/indra/llui/CMakeLists.txt
+++ b/indra/llui/CMakeLists.txt
@@ -159,6 +159,7 @@ set(llui_HEADER_FILES
     llnotificationslistener.h
     llnotificationsutil.h
     llnotificationtemplate.h
+	llnotificationvisibilityrule.h
     llpanel.h
     llprogressbar.h
     llradiogroup.h
-- 
cgit v1.2.3


From 8044661bd581fd7b6a25bd04d4c4f7e32e421faf Mon Sep 17 00:00:00 2001
From: Richard Linden <none@none>
Date: Fri, 10 Dec 2010 10:11:03 -0800
Subject: WIP XUI HTTP Auth dialog refactored LLWindowShade into seperate file
 improved layout of dialog improved dialog resizing logic Tab and Enter keys
 now work as expected in windowshade form added "modal" capability to window
 shade added HTTP Auth notifications to MOAP

---
 indra/llui/CMakeLists.txt | 2 ++
 1 file changed, 2 insertions(+)

(limited to 'indra/llui/CMakeLists.txt')

diff --git a/indra/llui/CMakeLists.txt b/indra/llui/CMakeLists.txt
index e98201ea63..063e3906c7 100644
--- a/indra/llui/CMakeLists.txt
+++ b/indra/llui/CMakeLists.txt
@@ -111,6 +111,7 @@ set(llui_SOURCE_FILES
     llviewmodel.cpp
     llview.cpp
     llviewquery.cpp
+    llwindowshade.cpp
     )
     
 set(llui_HEADER_FILES
@@ -209,6 +210,7 @@ set(llui_HEADER_FILES
     llviewmodel.h
     llview.h
     llviewquery.h
+    llwindowshade.h
     )
 
 set_source_files_properties(${llui_HEADER_FILES}
-- 
cgit v1.2.3