From 13221f67c465017f44ca46aeca23b0d820935825 Mon Sep 17 00:00:00 2001
From: Leviathan Linden <leviathan@lindenlab.com>
Date: Tue, 19 Sep 2023 09:40:08 -0700
Subject: add GameControl feature and SDL2 dependency

---
 indra/llui/CMakeLists.txt | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

(limited to 'indra/llui/CMakeLists.txt')

diff --git a/indra/llui/CMakeLists.txt b/indra/llui/CMakeLists.txt
index 69e1b57245..13a0250fe5 100644
--- a/indra/llui/CMakeLists.txt
+++ b/indra/llui/CMakeLists.txt
@@ -270,12 +270,13 @@ target_link_libraries(llui
         llmath
         ll::hunspell
         llcommon
+        ll::SDL2
     )
 
 # Add tests
 if(LL_TESTS)
   include(LLAddBuildTest)
-  set(test_libs llmessage llcorehttp llxml llrender llcommon ll::hunspell)
+  set(test_libs llmessage llcorehttp llxml llrender llcommon ll::hunspell ll::SDL2)
 
   SET(llui_TEST_SOURCE_FILES
       llurlmatch.cpp
@@ -285,7 +286,7 @@ if(LL_TESTS)
   # INTEGRATION TESTS
 
   if(NOT LINUX)
-    set(test_libs llui llmessage llcorehttp llxml llrender llcommon ll::hunspell )
+      set(test_libs llui llmessage llcorehttp llxml llrender llcommon ll::hunspell ll::SDL2)
     LL_ADD_INTEGRATION_TEST(llurlentry llurlentry.cpp "${test_libs}")
   endif(NOT LINUX)
 endif(LL_TESTS)
-- 
cgit v1.2.3