summaryrefslogtreecommitdiff
path: root/indra/win_updater/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'indra/win_updater/CMakeLists.txt')
-rw-r--r--indra/win_updater/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/indra/win_updater/CMakeLists.txt b/indra/win_updater/CMakeLists.txt
new file mode 100644
index 0000000000..6379d7c59b
--- /dev/null
+++ b/indra/win_updater/CMakeLists.txt
@@ -0,0 +1,30 @@
+# -*- cmake -*-
+
+project(win_updater)
+
+include(00-Common)
+include(LLCommon)
+include(Linking)
+
+include_directories(
+ ${LLCOMMON_INCLUDE_DIRS}
+ )
+
+set(win_updater_SOURCE_FILES updater.cpp)
+
+set(win_updater_HEADER_FILES CMakeLists.txt)
+
+set_source_files_properties(${win_updater_HEADER_FILES}
+ PROPERTIES HEADER_FILE_ONLY TRUE)
+
+list(APPEND win_updater_SOURCE_FILES ${win_updater_HEADER_FILES})
+
+add_executable(windows-updater WIN32 ${win_updater_SOURCE_FILES})
+
+target_link_libraries(windows-updater wininet)
+
+set_target_properties(windows-updater
+ PROPERTIES
+ LINK_FLAGS "/NODEFAULTLIB:MSVCRT"
+ LINK_FLAGS_DEBUG "/NODEFAULTLIB:\"LIBCMT;MSVCRTD\""
+ )