summaryrefslogtreecommitdiff
path: root/indra/newview/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'indra/newview/CMakeLists.txt')
-rw-r--r--indra/newview/CMakeLists.txt33
1 files changed, 33 insertions, 0 deletions
diff --git a/indra/newview/CMakeLists.txt b/indra/newview/CMakeLists.txt
index 767a280beb..9ee7b656c0 100644
--- a/indra/newview/CMakeLists.txt
+++ b/indra/newview/CMakeLists.txt
@@ -1774,9 +1774,42 @@ if (WINDOWS)
--distpath ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}
${CMAKE_SOURCE_DIR}/viewer_components/manager/SL_Launcher
COMMENT "Performing pyinstaller compile of SL_Launcher"
+
+ add_custom_command(
+ OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/apply_update.exe
+ COMMAND ${PYTHON_DIRECTORY}/Scripts/pyinstaller.exe
+ ARGS
+ --onefile
+ --log-level WARN
+ --distpath ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}
+ ${CMAKE_SOURCE_DIR}/viewer_components/manager/apply_update.py
+ COMMENT "Performing pyinstaller compile of updater"
+
+ add_custom_command(
+ OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/download_update.exe
+ COMMAND ${PYTHON_DIRECTORY}/Scripts/pyinstaller.exe
+ ARGS
+ --onefile
+ --log-level WARN
+ --distpath ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}
+ ${CMAKE_SOURCE_DIR}/viewer_components/manager/download_update.py
+ COMMENT "Performing pyinstaller compile of update downloader"
+
+ add_custom_command(
+ OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/update_manager.exe
+ COMMAND ${PYTHON_DIRECTORY}/Scripts/pyinstaller.exe
+ ARGS
+ --onefile
+ --log-level WARN
+ --distpath ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}
+ ${CMAKE_SOURCE_DIR}/viewer_components/manager/update_manager.py
+ COMMENT "Performing pyinstaller compile of update manager"
)
add_custom_target(compile_w_viewer_launcher ALL DEPENDS ${CMAKE_CFG_INTDIR}/SL_Launcher.exe)
+add_custom_target(compile_w_viewer_launcher ALL DEPENDS ${CMAKE_CFG_INTDIR}/apply_update.exe)
+add_custom_target(compile_w_viewer_launcher ALL DEPENDS ${CMAKE_CFG_INTDIR}/download_update.exe)
+add_custom_target(compile_w_viewer_launcher ALL DEPENDS ${CMAKE_CFG_INTDIR}/update_manager.exe)
add_custom_command(
OUTPUT ${CMAKE_CFG_INTDIR}/copy_touched.bat