summaryrefslogtreecommitdiff
path: root/indra/media_plugins/cef/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'indra/media_plugins/cef/CMakeLists.txt')
-rw-r--r--indra/media_plugins/cef/CMakeLists.txt22
1 files changed, 13 insertions, 9 deletions
diff --git a/indra/media_plugins/cef/CMakeLists.txt b/indra/media_plugins/cef/CMakeLists.txt
index 9bd6dbc5e9..16015be672 100644
--- a/indra/media_plugins/cef/CMakeLists.txt
+++ b/indra/media_plugins/cef/CMakeLists.txt
@@ -45,20 +45,28 @@ set(media_plugin_cef_SOURCE_FILES
media_plugin_cef.cpp
)
-set(media_plugin_webkit_HEADER_FILES
+set(media_plugin_cef_HEADER_FILES
volume_catcher.h
)
+set (media_plugin_cef_LINK_LIBRARIES
+ ${LLPLUGIN_LIBRARIES}
+ ${MEDIA_PLUGIN_BASE_LIBRARIES}
+ ${LLCOMMON_LIBRARIES}
+ ${CEF_PLUGIN_LIBRARIES}
+ ${PLUGIN_API_WINDOWS_LIBRARIES})
+
+
# Select which VolumeCatcher implementation to use
if (LINUX)
- message(FATAL_ERROR "CEF plugin has been enabled for a Linux compile.\n"
+ message(FATAL_ERROR "CEF plugin has been enabled for a Linux compile.\n"
" Please create a volume_catcher implementation for this platform.")
elseif (DARWIN)
list(APPEND media_plugin_cef_SOURCE_FILES mac_volume_catcher.cpp)
find_library(CORESERVICES_LIBRARY CoreServices)
find_library(AUDIOUNIT_LIBRARY AudioUnit)
- list(APPEND media_plugin_cef_SOURCE_FILES
+ list(APPEND media_plugin_cef_LINK_LIBRARIES
${CORESERVICES_LIBRARY} # for Component Manager calls
${AUDIOUNIT_LIBRARY} # for AudioUnit calls
)
@@ -66,7 +74,7 @@ elseif (WINDOWS)
list(APPEND media_plugin_cef_SOURCE_FILES windows_volume_catcher.cpp)
endif (LINUX)
-set_source_files_properties(${media_plugin_webkit_HEADER_FILES}
+set_source_files_properties(${media_plugin_cef_HEADER_FILES}
PROPERTIES HEADER_FILE_ONLY TRUE)
list(APPEND media_plugin_cef_SOURCE_FILES ${media_plugin_cef_HEADER_FILES})
@@ -83,11 +91,7 @@ add_dependencies(media_plugin_cef
)
target_link_libraries(media_plugin_cef
- ${LLPLUGIN_LIBRARIES}
- ${MEDIA_PLUGIN_BASE_LIBRARIES}
- ${LLCOMMON_LIBRARIES}
- ${CEF_PLUGIN_LIBRARIES}
- ${PLUGIN_API_WINDOWS_LIBRARIES}
+ ${media_plugin_cef_LINK_LIBRARIES}
)
if (WINDOWS)