summaryrefslogtreecommitdiff
path: root/indra/lscript/lscript_library/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'indra/lscript/lscript_library/CMakeLists.txt')
-rw-r--r--indra/lscript/lscript_library/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/indra/lscript/lscript_library/CMakeLists.txt b/indra/lscript/lscript_library/CMakeLists.txt
new file mode 100644
index 0000000000..f6bc67a994
--- /dev/null
+++ b/indra/lscript/lscript_library/CMakeLists.txt
@@ -0,0 +1,32 @@
+# -*- cmake -*-
+
+include(00-Common)
+include(LLCommon)
+include(LLMath)
+include(LScript)
+
+set(lscript_library_SOURCE_FILES
+ lscript_alloc.cpp
+ lscript_export.cpp
+ lscript_library.cpp
+ )
+
+set(lscript_library_HEADER_FILES
+ CMakeLists.txt
+
+ ../lscript_library.h
+ ../lscript_export.h
+ )
+
+set_source_files_properties(${lscript_library_HEADER_FILES}
+ PROPERTIES HEADER_FILE_ONLY TRUE)
+
+list(APPEND lscript_library_SOURCE_FILES ${lscript_library_HEADER_FILES})
+
+include_directories(
+ ${LLCOMMON_INCLUDE_DIRS}
+ ${LLMATH_INCLUDE_DIRS}
+ ${LSCRIPT_INCLUDE_DIRS}
+ )
+
+add_library (lscript_library ${lscript_library_SOURCE_FILES})