summaryrefslogtreecommitdiff
path: root/indra/llxml/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'indra/llxml/CMakeLists.txt')
-rw-r--r--indra/llxml/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/indra/llxml/CMakeLists.txt b/indra/llxml/CMakeLists.txt
new file mode 100644
index 0000000000..d86bc0d564
--- /dev/null
+++ b/indra/llxml/CMakeLists.txt
@@ -0,0 +1,36 @@
+# -*- cmake -*-
+
+project(llxml)
+
+include(00-Common)
+include(LLCommon)
+include(LLMath)
+include(LLXML)
+
+include_directories(
+ ${LLCOMMON_INCLUDE_DIRS}
+ ${LLMATH_INCLUDE_DIRS}
+ )
+
+set(llxml_SOURCE_FILES
+ llcontrol.cpp
+ llxmlnode.cpp
+ llxmlparser.cpp
+ llxmltree.cpp
+ )
+
+set(llxml_HEADER_FILES
+ CMakeLists.txt
+
+ llcontrol.h
+ llxmlnode.h
+ llxmlparser.h
+ llxmltree.h
+ )
+
+set_source_files_properties(${llxml_HEADER_FILES}
+ PROPERTIES HEADER_FILE_ONLY TRUE)
+
+list(APPEND llxml_SOURCE_FILES ${llxml_HEADER_FILES})
+
+add_library (llxml ${llxml_SOURCE_FILES})