summaryrefslogtreecommitdiff
path: root/indra/llwindow/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'indra/llwindow/CMakeLists.txt')
-rw-r--r--indra/llwindow/CMakeLists.txt8
1 files changed, 3 insertions, 5 deletions
diff --git a/indra/llwindow/CMakeLists.txt b/indra/llwindow/CMakeLists.txt
index 4d5c6053fb..6b70d66d7a 100644
--- a/indra/llwindow/CMakeLists.txt
+++ b/indra/llwindow/CMakeLists.txt
@@ -51,7 +51,6 @@ set(llwindow_LINK_LIBRARIES
llcommon
llimage
llmath
- #llrender
llfilesystem
llxml
ll::glh_linear
@@ -65,8 +64,8 @@ include_directories(${CMAKE_SOURCE_DIR}/llrender)
# Libraries on which this library depends, needed for Linux builds
# Sort by high-level to low-level
if (USESYSTEMLIBS AND NOT DARWIN)
- list(APPEND viewer_SOURCE_FILES
- llkeyboardsdl.cpp
+ list(APPEND viewer_SOURCE_FILES
+ llkeyboardsdl.cpp
llwindowsdl.cpp
)
list(APPEND viewer_HEADER_FILES
@@ -86,7 +85,6 @@ if (USESYSTEMLIBS AND NOT DARWIN)
fontconfig # For FCInit and other FC* functions.
)
endif (BUILD_HEADLESS)
-
endif (USESYSTEMLIBS AND NOT DARWIN)
if (DARWIN)
@@ -182,7 +180,7 @@ endif (SDL_FOUND)
target_link_libraries (llwindow ${llwindow_LINK_LIBRARIES})
target_include_directories(llwindow INTERFACE ${CMAKE_CURRENT_SOURCE_DIR})
-
+
if (DARWIN)
include(CMakeFindFrameworks)
find_library(CARBON_LIBRARY Carbon)