summaryrefslogtreecommitdiff
path: root/indra/llrender/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'indra/llrender/CMakeLists.txt')
-rw-r--r--indra/llrender/CMakeLists.txt7
1 files changed, 1 insertions, 6 deletions
diff --git a/indra/llrender/CMakeLists.txt b/indra/llrender/CMakeLists.txt
index 7d42043613..cb98886f9b 100644
--- a/indra/llrender/CMakeLists.txt
+++ b/indra/llrender/CMakeLists.txt
@@ -91,12 +91,6 @@ endif (BUILD_HEADLESS)
add_library (llrender ${llrender_SOURCE_FILES})
set_target_include_dirs(llrender ${CMAKE_CURRENT_SOURCE_DIR})
-if (SDL_FOUND)
- set_property(TARGET llrender
- PROPERTY COMPILE_DEFINITIONS LL_SDL=1
- )
-endif (SDL_FOUND)
-
# Libraries on which this library depends, needed for Linux builds
# Sort by high-level to low-level
target_link_libraries(llrender
@@ -106,6 +100,7 @@ target_link_libraries(llrender
llfilesystem
llxml
llwindow
+ sdl::sdl
freetype::freetype
OpenGL::GL
OpenGL::GLU