summaryrefslogtreecommitdiff
path: root/indra/llprimitive/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'indra/llprimitive/CMakeLists.txt')
-rw-r--r--indra/llprimitive/CMakeLists.txt7
1 files changed, 3 insertions, 4 deletions
diff --git a/indra/llprimitive/CMakeLists.txt b/indra/llprimitive/CMakeLists.txt
index f24d8ed3b3..dea85f8f4f 100644
--- a/indra/llprimitive/CMakeLists.txt
+++ b/indra/llprimitive/CMakeLists.txt
@@ -8,6 +8,7 @@ include(LLCoreHttp)
include(LLPhysicsExtensions)
include(LLPrimitive)
include(GLH)
+include(GLM)
include(TinyGLTF)
set(llprimitive_SOURCE_FILES
@@ -73,10 +74,8 @@ target_link_libraries(llprimitive
ll::glh_linear
)
-if (NOT (USE_AUTOBUILD_3P OR USE_CONAN))
- set_source_files_properties(lldaeloader.cpp PROPERTIES COMPILE_FLAGS
- -std=c++14)
- add_subdirectory(llphysicsextensions)
+if (USESYSTEMLIBS)
+ add_subdirectory(llphysicsextensions)
endif ()
include(LibraryInstall)