summaryrefslogtreecommitdiff
path: root/indra/llmeshoptimizer/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'indra/llmeshoptimizer/CMakeLists.txt')
-rw-r--r--indra/llmeshoptimizer/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/indra/llmeshoptimizer/CMakeLists.txt b/indra/llmeshoptimizer/CMakeLists.txt
index 1eea19de66..016794cfad 100644
--- a/indra/llmeshoptimizer/CMakeLists.txt
+++ b/indra/llmeshoptimizer/CMakeLists.txt
@@ -6,9 +6,11 @@ include(MESHOPTIMIZER)
include(00-Common)
include(LLCommon)
+include(LLMath)
include_directories(
${LLCOMMON_INCLUDE_DIRS}
+ ${LLMATH_INCLUDE_DIRS}
${LLMESHOPTIMIZER_INCLUDE_DIR}
${MESHOPTIMIZER_INCLUDE_DIRS}
${LIBS_PREBUILT_DIR}/include #access to boost headers, needed for LLError
@@ -34,7 +36,8 @@ list(APPEND llmeshoptimizer_SOURCE_FILES ${llmeshoptimizer_HEADER_FILES})
target_link_libraries(llmeshoptimizer
${LLCOMMON_LIBRARIES}
- ${MESHOPTIMIZER_LIBRARY})
+ ${LLMATH_LIBRARIES}
+ ${MESHOPTIMIZER_LIBRARIES})
# Add tests