summaryrefslogtreecommitdiff
path: root/indra/llinventory/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'indra/llinventory/CMakeLists.txt')
-rw-r--r--indra/llinventory/CMakeLists.txt56
1 files changed, 56 insertions, 0 deletions
diff --git a/indra/llinventory/CMakeLists.txt b/indra/llinventory/CMakeLists.txt
new file mode 100644
index 0000000000..b70548a9ba
--- /dev/null
+++ b/indra/llinventory/CMakeLists.txt
@@ -0,0 +1,56 @@
+# -*- cmake -*-
+
+project(llinventory)
+
+include(00-Common)
+include(LLCommon)
+include(LLMath)
+include(LLMessage)
+include(LLXML)
+
+include_directories(
+ ${LLCOMMON_INCLUDE_DIRS}
+ ${LLMATH_INCLUDE_DIRS}
+ ${LLMESSAGE_INCLUDE_DIRS}
+ ${LLXML_INCLUDE_DIRS}
+ )
+
+set(llinventory_SOURCE_FILES
+ llcategory.cpp
+ lleconomy.cpp
+ llinventory.cpp
+ llinventorytype.cpp
+ lllandmark.cpp
+ llnotecard.cpp
+ llparcel.cpp
+ llpermissions.cpp
+ llsaleinfo.cpp
+ lltransactionflags.cpp
+ lluserrelations.cpp
+ )
+
+set(llinventory_HEADER_FILES
+ CMakeLists.txt
+
+ llcategory.h
+ lleconomy.h
+ llinventory.h
+ llinventorytype.h
+ lllandmark.h
+ llnotecard.h
+ llparcel.h
+ llparcelflags.h
+ llpermissions.h
+ llpermissionsflags.h
+ llsaleinfo.h
+ lltransactionflags.h
+ lltransactiontypes.h
+ lluserrelations.h
+ )
+
+set_source_files_properties(${llinventory_HEADER_FILES}
+ PROPERTIES HEADER_FILE_ONLY TRUE)
+
+list(APPEND llinventory_SOURCE_FILES ${llinventory_HEADER_FILES})
+
+add_library (llinventory ${llinventory_SOURCE_FILES})