summaryrefslogtreecommitdiff
path: root/indra/llimage/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'indra/llimage/CMakeLists.txt')
-rw-r--r--indra/llimage/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/indra/llimage/CMakeLists.txt b/indra/llimage/CMakeLists.txt
index 1a4d92bc34..a155d19407 100644
--- a/indra/llimage/CMakeLists.txt
+++ b/indra/llimage/CMakeLists.txt
@@ -49,8 +49,11 @@ set_source_files_properties(${llimage_HEADER_FILES}
list(APPEND llimage_SOURCE_FILES ${llimage_HEADER_FILES})
add_library (llimage ${llimage_SOURCE_FILES})
-target_link_libraries(
- llimage
+# Libraries on which this library depends, needed for Linux builds
+# Sort by high-level to low-level
+target_link_libraries(llimage
+ llcommon
+ llimagej2coj # *HACK: In theory a noop for KDU builds?
${JPEG_LIBRARIES}
${PNG_LIBRARIES}
${ZLIB_LIBRARIES}