summaryrefslogtreecommitdiff
path: root/indra/llcorehttp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'indra/llcorehttp/CMakeLists.txt')
-rw-r--r--indra/llcorehttp/CMakeLists.txt13
1 files changed, 7 insertions, 6 deletions
diff --git a/indra/llcorehttp/CMakeLists.txt b/indra/llcorehttp/CMakeLists.txt
index 9dbc6f447e..11b2e3e929 100644
--- a/indra/llcorehttp/CMakeLists.txt
+++ b/indra/llcorehttp/CMakeLists.txt
@@ -101,12 +101,13 @@ target_link_libraries(
)
# tests
-if (LL_TESTS)
+set(LLCOREHTTP_TESTS ON CACHE BOOL
+ "Build and run llcorehttp integration tests specifically")
+if (LL_TESTS AND LLCOREHTTP_TESTS)
SET(llcorehttp_TEST_SOURCE_FILES
- tests/test_allocator.cpp
)
- set(llcorehttp_TEST_HEADER_FILS
+ set(llcorehttp_TEST_HEADER_FILES
tests/test_httpstatus.hpp
tests/test_refcounted.hpp
tests/test_httpoperation.hpp
@@ -149,7 +150,7 @@ if (LL_TESTS)
${PYTHON_EXECUTABLE}
"${CMAKE_CURRENT_SOURCE_DIR}/tests/test_llcorehttp_peer.py"
)
-
+
if (DARWIN)
# Path inside the app bundle where we'll need to copy libraries
set(LL_TEST_DESTINATION_DIR
@@ -198,6 +199,7 @@ endif (DARWIN)
)
set(example_libs
+ ${LEGACY_STDIO_LIBS}
${LLCOREHTTP_LIBRARIES}
${WINDOWS_LIBRARIES}
${LLMESSAGE_LIBRARIES}
@@ -231,5 +233,4 @@ endif (DARWIN)
target_link_libraries(http_texture_load ${example_libs})
-endif (LL_TESTS)
-
+endif (LL_TESTS AND LLCOREHTTP_TESTS)