summaryrefslogtreecommitdiff
path: root/indra/llcorehttp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'indra/llcorehttp/CMakeLists.txt')
-rw-r--r--indra/llcorehttp/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/indra/llcorehttp/CMakeLists.txt b/indra/llcorehttp/CMakeLists.txt
index 5650c4c8ba..aa56407e35 100644
--- a/indra/llcorehttp/CMakeLists.txt
+++ b/indra/llcorehttp/CMakeLists.txt
@@ -8,9 +8,10 @@ include(OpenSSL)
include(NGHTTP2)
include(ZLIBNG)
include(LLCoreHttp)
+if (LL_TESTS)
include(LLAddBuildTest)
+endif ()
include(LLCommon)
-include(Tut)
include(bugsplat)
set(llcorehttp_SOURCE_FILES
@@ -92,6 +93,8 @@ target_include_directories( llcorehttp INTERFACE ${CMAKE_CURRENT_SOURCE_DIR})
# lead to circular dependencies (or in case of cmake, the first project declaring it's dependencies wins)
target_include_directories( llcorehttp PRIVATE ${CMAKE_CURRENT_SOURCE_DIR}/../llmessage)
+include(LibraryInstall)
+
# tests
set(LLCOREHTTP_TESTS ON CACHE BOOL
"Build and run llcorehttp integration tests specifically")