summaryrefslogtreecommitdiff
path: root/indra/llcommon/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'indra/llcommon/CMakeLists.txt')
-rw-r--r--indra/llcommon/CMakeLists.txt38
1 files changed, 26 insertions, 12 deletions
diff --git a/indra/llcommon/CMakeLists.txt b/indra/llcommon/CMakeLists.txt
index a504e71340..eaf32f68ea 100644
--- a/indra/llcommon/CMakeLists.txt
+++ b/indra/llcommon/CMakeLists.txt
@@ -16,6 +16,8 @@ include(Tracy)
set(llcommon_SOURCE_FILES
apply.cpp
commoncontrol.cpp
+ coro_scheduler.cpp
+ hbxxh.cpp
indra_constants.cpp
lazyeventapi.cpp
llapp.cpp
@@ -53,8 +55,8 @@ set(llcommon_SOURCE_FILES
llframetimer.cpp
llheartbeat.cpp
llheteromap.cpp
- llinitparam.cpp
llinitdestroyclass.cpp
+ llinitparam.cpp
llinstancetracker.cpp
llkeybind.cpp
llleap.cpp
@@ -64,15 +66,15 @@ set(llcommon_SOURCE_FILES
llmd5.cpp
llmemory.cpp
llmemorystream.cpp
- llmetrics.cpp
llmetricperformancetester.cpp
+ llmetrics.cpp
llmortician.cpp
llmutex.cpp
- llptrto.cpp
llpredicate.cpp
llprocess.cpp
llprocessor.cpp
llprocinfo.cpp
+ llptrto.cpp
llqueuedthread.cpp
llrand.cpp
llrefcount.cpp
@@ -102,9 +104,13 @@ set(llcommon_SOURCE_FILES
lluriparser.cpp
lluuid.cpp
llworkerthread.cpp
- hbxxh.cpp
- u64.cpp
+ lockstatic.cpp
+ lua_function.cpp
+ lualistener.cpp
+ resultset.cpp
threadpool.cpp
+ throttle.cpp
+ u64.cpp
workqueue.cpp
StackWalker.cpp
)
@@ -117,10 +123,12 @@ set(llcommon_HEADER_FILES
chrono.h
classic_callback.h
commoncontrol.h
+ coro_scheduler.h
ctype_workaround.h
fix_macros.h
fsyspath.h
function_types.h
+ hbxxh.h
indra_constants.h
lazyeventapi.h
linden_common.h
@@ -139,6 +147,7 @@ set(llcommon_HEADER_FILES
llcommonutils.h
llcond.h
llcoros.h
+ llcoromutex.h
llcrc.h
llcriticaldamp.h
lldate.h
@@ -155,9 +164,9 @@ set(llcommon_HEADER_FILES
lleventapi.h
lleventcoro.h
lleventdispatcher.h
+ lleventemitter.h
lleventfilter.h
llevents.h
- lleventemitter.h
llexception.h
llfasttimer.h
llfile.h
@@ -174,6 +183,7 @@ set(llcommon_HEADER_FILES
llinitparam.h
llinstancetracker.h
llinstancetrackersubclass.h
+ llinttracker.h
llkeybind.h
llkeythrottle.h
llleap.h
@@ -184,14 +194,12 @@ set(llcommon_HEADER_FILES
llmd5.h
llmemory.h
llmemorystream.h
- llmetrics.h
llmetricperformancetester.h
+ llmetrics.h
llmortician.h
llmutex.h
llnametable.h
llpointer.h
- llprofiler.h
- llprofilercategories.h
llpounceable.h
llpredicate.h
llpreprocessor.h
@@ -199,6 +207,8 @@ set(llcommon_HEADER_FILES
llprocess.h
llprocessor.h
llprocinfo.h
+ llprofiler.h
+ llprofilercategories.h
llptrto.h
llqueuedthread.h
llrand.h
@@ -216,14 +226,14 @@ set(llcommon_HEADER_FILES
llsimplehash.h
llsingleton.h
llstacktrace.h
+ llstaticstringtable.h
+ llstatsaccumulator.h
llstl.h
llstreamqueue.h
llstreamtools.h
llstrider.h
llstring.h
llstringtable.h
- llstaticstringtable.h
- llstatsaccumulator.h
llsys.h
lltempredirect.h
llthread.h
@@ -242,13 +252,17 @@ set(llcommon_HEADER_FILES
lluuid.h
llwin32headers.h
llworkerthread.h
- hbxxh.h
lockstatic.h
+ lua_function.h
+ lualistener.h
+ resultset.h
stdtypes.h
stringize.h
+ tempset.h
threadpool.h
threadpool_fwd.h
threadsafeschedule.h
+ throttle.h
timer.h
tuple.h
u64.h