summaryrefslogtreecommitdiff
path: root/indra/llcommon/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'indra/llcommon/CMakeLists.txt')
-rw-r--r--indra/llcommon/CMakeLists.txt12
1 files changed, 4 insertions, 8 deletions
diff --git a/indra/llcommon/CMakeLists.txt b/indra/llcommon/CMakeLists.txt
index e611847a24..a74309385f 100644
--- a/indra/llcommon/CMakeLists.txt
+++ b/indra/llcommon/CMakeLists.txt
@@ -12,7 +12,6 @@ if (USE_AUTOBUILD_3P OR USE_CONAN)
include(Copy3rdPartyLibs)
endif ()
include(ZLIBNG)
-include(URIPARSER)
include(Tracy)
@@ -21,8 +20,6 @@ set(llcommon_SOURCE_FILES
commoncontrol.cpp
indra_constants.cpp
lazyeventapi.cpp
- llallocator.cpp
- llallocator_heap_profile.cpp
llapp.cpp
llapr.cpp
llassettype.cpp
@@ -31,7 +28,6 @@ set(llcommon_SOURCE_FILES
llbase64.cpp
llbitpack.cpp
llcallbacklist.cpp
- llcallstack.cpp
llcleanup.cpp
llcommon.cpp
llcommonutils.cpp
@@ -130,8 +126,6 @@ set(llcommon_HEADER_FILES
lazyeventapi.h
linden_common.h
llalignedarray.h
- llallocator.h
- llallocator_heap_profile.h
llapp.h
llapr.h
llassettype.h
@@ -141,7 +135,6 @@ set(llcommon_HEADER_FILES
llbitpack.h
llboost.h
llcallbacklist.h
- llcallstack.h
llcleanup.h
llcommon.h
llcommonutils.h
@@ -274,6 +267,10 @@ if (DARWIN)
list(APPEND llcommon_SOURCE_FILES llsys_objc.mm)
endif (DARWIN)
+if (USE_TRACY)
+ list(APPEND llcommon_SOURCE_FILES llprofiler.cpp)
+endif ()
+
list(APPEND llcommon_SOURCE_FILES ${llcommon_HEADER_FILES})
add_library (llcommon ${llcommon_SOURCE_FILES})
@@ -284,7 +281,6 @@ target_link_libraries(
ll::expat
ll::zlib-ng
ll::boost
- ll::uriparser
ll::oslibraries
ll::tracy
)