summaryrefslogtreecommitdiff
path: root/indra/llcommon/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'indra/llcommon/CMakeLists.txt')
-rw-r--r--indra/llcommon/CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/indra/llcommon/CMakeLists.txt b/indra/llcommon/CMakeLists.txt
index ed7ac8deb7..b1dc65ffc5 100644
--- a/indra/llcommon/CMakeLists.txt
+++ b/indra/llcommon/CMakeLists.txt
@@ -289,8 +289,12 @@ add_dependencies(llcommon stage_third_party_libs)
else ()
target_compile_options(${PROJECT_NAME} PUBLIC -Wno-deprecated-declarations)
if (CMAKE_CXX_COMPILER_ID MATCHES "GNU")
- set_source_files_properties(llsdutil.cpp PROPERTIES
- COMPILE_FLAGS -Wno-stringop-truncation)
+ set_source_files_properties(
+ llapp.cpp
+ llsdutil.cpp
+ PROPERTIES COMPILE_FLAGS -Wno-stringop-truncation)
+ set_source_files_properties(llevent.cpp PROPERTIES
+ COMPILE_FLAGS -Wno-nonnull)
endif()
endif ()