summaryrefslogtreecommitdiff
path: root/indra/llaudio/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'indra/llaudio/CMakeLists.txt')
-rw-r--r--indra/llaudio/CMakeLists.txt60
1 files changed, 60 insertions, 0 deletions
diff --git a/indra/llaudio/CMakeLists.txt b/indra/llaudio/CMakeLists.txt
new file mode 100644
index 0000000000..27e33b8cf3
--- /dev/null
+++ b/indra/llaudio/CMakeLists.txt
@@ -0,0 +1,60 @@
+# -*- cmake -*-
+
+project(llaudio)
+
+include(00-Common)
+include(Audio)
+include(FMOD)
+include(LLCommon)
+include(LLMath)
+include(LLMessage)
+include(LLVFS)
+
+include_directories(
+ ${FMOD_INCLUDE_DIR}
+ ${LLCOMMON_INCLUDE_DIRS}
+ ${LLMATH_INCLUDE_DIRS}
+ ${LLMESSAGE_INCLUDE_DIRS}
+ ${LLVFS_INCLUDE_DIRS}
+ ${OGG_INCLUDE_DIRS}
+ ${VORBISENC_INCLUDE_DIRS}
+ ${VORBISFILE_INCLUDE_DIRS}
+ ${VORBIS_INCLUDE_DIRS}
+ )
+
+set(llaudio_SOURCE_FILES
+ audioengine.cpp
+ listener.cpp
+ llaudiodecodemgr.cpp
+ vorbisdecode.cpp
+ vorbisencode.cpp
+ )
+
+set(llaudio_HEADER_FILES
+ CMakeLists.txt
+
+ audioengine.h
+ listener.h
+ llaudiodecodemgr.h
+ vorbisdecode.h
+ vorbisencode.h
+ )
+
+if (FMOD)
+ list(APPEND llaudio_SOURCE_FILES
+ audioengine_fmod.cpp
+ listener_fmod.cpp
+ )
+
+ list(APPEND llaudio_HEADER_FILES
+ audioengine_fmod.h
+ listener_fmod.h
+ )
+endif (FMOD)
+
+set_source_files_properties(${llaudio_HEADER_FILES}
+ PROPERTIES HEADER_FILE_ONLY TRUE)
+
+list(APPEND llaudio_SOURCE_FILES ${llaudio_HEADER_FILES})
+
+add_library (llaudio ${llaudio_SOURCE_FILES})