summaryrefslogtreecommitdiff
path: root/indra/appearance_utility/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'indra/appearance_utility/CMakeLists.txt')
-rw-r--r--indra/appearance_utility/CMakeLists.txt21
1 files changed, 2 insertions, 19 deletions
diff --git a/indra/appearance_utility/CMakeLists.txt b/indra/appearance_utility/CMakeLists.txt
index dec71feea2..92898fa48b 100644
--- a/indra/appearance_utility/CMakeLists.txt
+++ b/indra/appearance_utility/CMakeLists.txt
@@ -3,38 +3,27 @@
project(appearance_utility)
include(00-Common)
-include(CURL)
-include(CARes)
-include(OpenSSL)
-include(UI)
include(LLAppearance)
include(LLCharacter)
include(LLCommon)
include(LLImage)
include(LLInventory)
include(LLMath)
-include(LLKDU)
include(LLRender)
include(LLVFS)
include(LLXML)
-include(LLUI)
include(Linking)
+include(GooglePerfTools)
include_directories(
${LLCOMMON_INCLUDE_DIRS}
${LLVFS_INCLUDE_DIRS}
${LLXML_INCLUDE_DIRS}
- ${LLUI_INCLUDE_DIRS}
${LLCHARACTER_INCLUDE_DIRS}
- ${LLKDU_INCLUDE_DIRS}
${LLIMAGE_INCLUDE_DIRS}
${LLMATH_INCLUDE_DIRS}
${LLINVENTORY_INCLUDE_DIRS}
${LLRENDER_INCLUDE_DIRS}
- ${CURL_INCLUDE_DIRS}
- ${CARES_INCLUDE_DIRS}
- ${OPENSSL_INCLUDE_DIRS}
- ${UI_INCLUDE_DIRS}
${LLAPPEARANCE_INCLUDE_DIRS}
)
@@ -70,13 +59,7 @@ add_executable(appearance-utility-bin ${appearance_utility_SOURCE_FILES})
target_link_libraries(appearance-utility-bin
${LLAPPEARANCE_LIBRARIES}
- ${LLCHARACTER_LIBRARIES}
- ${LLRENDER_LIBRARIES}
- ${LLUI_LIBRARIES}
- ${UI_LIBRARIES}
- ${LLIMAGE_LIBRARIES}
- ${LLKDU_LIBRARIES}
- ${KDU_LIBRARY}
+ ${TCMALLOC_LIBRARIES}
)
add_custom_target(appearance-utility-bin-target ALL