summaryrefslogtreecommitdiff
path: root/indra/viewer_components/updater/CMakeLists.txt
diff options
context:
space:
mode:
authorRider Linden <rider@lindenlab.com>2015-12-18 13:53:03 -0800
committerRider Linden <rider@lindenlab.com>2015-12-18 13:53:03 -0800
commitb98469bd7db06973e6058118551e500dc094d3c0 (patch)
treef919aac17afcdd01734ce46652069651c5bad4d9 /indra/viewer_components/updater/CMakeLists.txt
parent6fca0eaa00f4469a3db06f0ec8c88ba8b58b5647 (diff)
Disable unit test on Linux only
Diffstat (limited to 'indra/viewer_components/updater/CMakeLists.txt')
-rwxr-xr-xindra/viewer_components/updater/CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/indra/viewer_components/updater/CMakeLists.txt b/indra/viewer_components/updater/CMakeLists.txt
index 48c065c2ed..7f866336d9 100755
--- a/indra/viewer_components/updater/CMakeLists.txt
+++ b/indra/viewer_components/updater/CMakeLists.txt
@@ -73,18 +73,23 @@ if(LL_TESTS)
llupdaterservice.cpp
)
+set(test_libs
+ ${LLCOMMON_LIBRARIES})
+
set_source_files_properties(
llupdaterservice.cpp
PROPERTIES
- LL_TEST_ADDITIONAL_LIBRARIES "${BOOST_SYSTEM_LIBRARY}"
+ LL_TEST_ADDITIONAL_LIBRARIES ${test_libs}
# *NOTE:Mani - I was trying to use the preprocessor seam to mock out
# llifstream (and other) llcommon classes. It didn't work
# because of the windows declspec(dllimport)attribute.
# LL_TEST_ADDITIONAL_CFLAGS "-Dllifstream=llus_mock_llifstream"
)
- LL_ADD_PROJECT_UNIT_TESTS(llupdaterservice "${llupdater_service_TEST_SOURCE_FILES}")
+if (NOT LINUX)
+ LL_ADD_PROJECT_UNIT_TESTS(llupdaterservice "${llupdater_service_TEST_SOURCE_FILES}" ${test_libs})
+endif (NOT LINUX)
endif(LL_TESTS)
set(UPDATER_INCLUDE_DIRS