summaryrefslogtreecommitdiff
path: root/indra/viewer_components/updater/CMakeLists.txt
diff options
context:
space:
mode:
authorMark Palange (Mani) <palange@lindenlab.com>2010-11-10 14:26:14 -0800
committerMark Palange (Mani) <palange@lindenlab.com>2010-11-10 14:26:14 -0800
commitb2e84d739b4f5c00b497e57e892fc10d78af8b76 (patch)
treef035b0be5134c0286f4af7d4f5835ea533ec2e3f /indra/viewer_components/updater/CMakeLists.txt
parentf42bb00627f756b277496ec203d567cac31b3438 (diff)
CHOP-151 Adding startup updater flow to drive update installation and resume.
Diffstat (limited to 'indra/viewer_components/updater/CMakeLists.txt')
-rw-r--r--indra/viewer_components/updater/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/indra/viewer_components/updater/CMakeLists.txt b/indra/viewer_components/updater/CMakeLists.txt
index 64a0f98c2a..980599dd48 100644
--- a/indra/viewer_components/updater/CMakeLists.txt
+++ b/indra/viewer_components/updater/CMakeLists.txt
@@ -57,10 +57,13 @@ if(LL_TESTS)
llupdaterservice.cpp
)
-# set_source_files_properties(
+# *NOTE:Mani - I was trying to use the preprocessor seam to mock out
+# llifstream (and other) llcommon classes. I didn't work
+# because of the windows declspec(dllimport)attribute.
+#set_source_files_properties(
# llupdaterservice.cpp
# PROPERTIES
-# LL_TEST_ADDITIONAL_LIBRARIES "${PTH_LIBRARIES}"
+# LL_TEST_ADDITIONAL_CFLAGS "-Dllifstream=llus_mock_llifstream"
# )
LL_ADD_PROJECT_UNIT_TESTS(llupdaterservice "${llupdater_service_TEST_SOURCE_FILES}")