summaryrefslogtreecommitdiff
path: root/indra/viewer_components/updater/CMakeLists.txt
diff options
context:
space:
mode:
authorMark Palange (Mani) <palange@lindenlab.com>2010-11-10 14:28:54 -0800
committerMark Palange (Mani) <palange@lindenlab.com>2010-11-10 14:28:54 -0800
commit7eed962a6237f74ec980e06d53886259ef225c55 (patch)
tree6f90cd7736c74164f5cfaff071ecfc9f63b7a46f /indra/viewer_components/updater/CMakeLists.txt
parentb2e84d739b4f5c00b497e57e892fc10d78af8b76 (diff)
parent9d33a548b636fa739de2aa11ba9ed02b301c53a5 (diff)
Merge
Diffstat (limited to 'indra/viewer_components/updater/CMakeLists.txt')
-rw-r--r--indra/viewer_components/updater/CMakeLists.txt19
1 files changed, 18 insertions, 1 deletions
diff --git a/indra/viewer_components/updater/CMakeLists.txt b/indra/viewer_components/updater/CMakeLists.txt
index 980599dd48..c5ccfbf66a 100644
--- a/indra/viewer_components/updater/CMakeLists.txt
+++ b/indra/viewer_components/updater/CMakeLists.txt
@@ -6,6 +6,7 @@ include(00-Common)
if(LL_TESTS)
include(LLAddBuildTest)
endif(LL_TESTS)
+include(CMakeCopyIfDifferent)
include(CURL)
include(LLCommon)
include(LLMessage)
@@ -24,12 +25,14 @@ set(updater_service_SOURCE_FILES
llupdaterservice.cpp
llupdatechecker.cpp
llupdatedownloader.cpp
+ llupdateinstaller.cpp
)
set(updater_service_HEADER_FILES
llupdaterservice.h
llupdatechecker.h
llupdatedownloader.h
+ llupdateinstaller.h
)
set_source_files_properties(${updater_service_HEADER_FILES}
@@ -49,7 +52,6 @@ target_link_libraries(llupdaterservice
${LLMESSAGE_LIBRARIES}
${LLPLUGIN_LIBRARIES}
${LLVFS_LIBRARIES}
- ${CURL_LIBRARIES}
)
if(LL_TESTS)
@@ -78,3 +80,18 @@ set(UPDATER_LIBRARIES
llupdaterservice
CACHE INTERNAL ""
)
+
+# Copy install script.
+if(DARWIN)
+ copy_if_different(
+ "${CMAKE_CURRENT_SOURCE_DIR}/scripts/darwin"
+ "${CMAKE_CURRENT_BINARY_DIR}"
+ update_installer_targets
+ "update_install"
+ )
+endif()
+add_custom_target(copy_update_install ALL DEPENDS ${update_installer_targets})
+add_dependencies(llupdaterservice copy_update_install)
+
+
+ \ No newline at end of file