summaryrefslogtreecommitdiff
path: root/indra/viewer_components/updater/CMakeLists.txt
diff options
context:
space:
mode:
authorsimon <none@none>2013-05-09 14:10:45 -0700
committersimon <none@none>2013-05-09 14:10:45 -0700
commitee2fce8790b69d61845cc32fbf7cdce8a33b0dab (patch)
tree5060f42dca293102c868038f127c1a74f5c4a6aa /indra/viewer_components/updater/CMakeLists.txt
parentcd8e0b92e1c8f9f8544b1011e61c21c7789b93b7 (diff)
parent8895e795763d14c3dae495b3648da3d4a52ba30a (diff)
Merge downstream code and viewer-beta
Diffstat (limited to 'indra/viewer_components/updater/CMakeLists.txt')
-rwxr-xr-x[-rw-r--r--]indra/viewer_components/updater/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/indra/viewer_components/updater/CMakeLists.txt b/indra/viewer_components/updater/CMakeLists.txt
index de7e336341..61fd4220e0 100644..100755
--- a/indra/viewer_components/updater/CMakeLists.txt
+++ b/indra/viewer_components/updater/CMakeLists.txt
@@ -19,6 +19,7 @@ include_directories(
${LLPLUGIN_INCLUDE_DIRS}
${LLVFS_INCLUDE_DIRS}
${CURL_INCLUDE_DIRS}
+ ${CMAKE_SOURCE_DIR}/newview
)
include_directories(SYSTEM
${LLCOMMON_SYSTEM_INCLUDE_DIRS}
@@ -41,6 +42,12 @@ set(updater_service_HEADER_FILES
set_source_files_properties(${updater_service_HEADER_FILES}
PROPERTIES HEADER_FILE_ONLY TRUE)
+set_source_files_properties(
+ llupdaterservice.cpp
+ PROPERTIES
+ COMPILE_DEFINITIONS "${VIEWER_CHANNEL_VERSION_DEFINES}" # see BuildVersion.cmake
+ )
+
list(APPEND
updater_service_SOURCE_FILES
${updater_service_HEADER_FILES}