summaryrefslogtreecommitdiff
path: root/indra/test_apps/llplugintest/CMakeLists.txt
diff options
context:
space:
mode:
authorVadim Savchuk <vsavchuk@productengine.com>2009-12-16 14:56:18 +0200
committerVadim Savchuk <vsavchuk@productengine.com>2009-12-16 14:56:18 +0200
commit734f37816ef35089bc0f5710dc1f9684bc5b9b69 (patch)
tree38bcf9ca3bce50b9d0fba8b717b910bcbba638d7 /indra/test_apps/llplugintest/CMakeLists.txt
parente398f41074f40c0779d7cc29a8127540ac78b1f9 (diff)
parent88291b378eda6178ae3f2cbda60feddf0e68e3fa (diff)
Merge from default branch.
--HG-- branch : product-engine
Diffstat (limited to 'indra/test_apps/llplugintest/CMakeLists.txt')
-rw-r--r--indra/test_apps/llplugintest/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/indra/test_apps/llplugintest/CMakeLists.txt b/indra/test_apps/llplugintest/CMakeLists.txt
index 0011daaec6..89e2d8582d 100644
--- a/indra/test_apps/llplugintest/CMakeLists.txt
+++ b/indra/test_apps/llplugintest/CMakeLists.txt
@@ -338,6 +338,13 @@ add_custom_command(TARGET llmediaplugintest POST_BUILD
DEPENDS ${BUILT_SLPLUGIN}
)
+get_target_property(BUILT_LLCOMMON llcommon LOCATION)
+add_custom_command(TARGET llmediaplugintest POST_BUILD
+ COMMAND ${CMAKE_COMMAND} -E copy ${BUILT_LLCOMMON} ${PLUGINS_DESTINATION_DIR}
+ DEPENDS ${BUILT_LLCOMMON}
+)
+
+
if (DARWIN OR WINDOWS)
get_target_property(BUILT_WEBKIT_PLUGIN media_plugin_webkit LOCATION)
add_custom_command(TARGET llmediaplugintest POST_BUILD
@@ -435,6 +442,7 @@ if(WINDOWS)
qtnetwork4.dll
qtopengl4.dll
qtwebkit4.dll
+ qtxmlpatterns4.dll
ssleay32.dll
)
copy_if_different(