summaryrefslogtreecommitdiff
path: root/indra/test/CMakeLists.txt
diff options
context:
space:
mode:
authorLogan Dethrow <log@lindenlab.com>2011-09-13 14:41:00 -0400
committerLogan Dethrow <log@lindenlab.com>2011-09-13 14:41:00 -0400
commit15a3df2f084947fb977e87817f786c7aa35d3af7 (patch)
treec2494c0fff59287efe38c3f0ef72acc6afe0f872 /indra/test/CMakeLists.txt
parentdc58b5207b3ed92dfcf7ecf16c7844453faac18f (diff)
Always build indra/test, run if LL_TESTS is enabled. Removed python test run command since there are no python tests in the viewer.
Diffstat (limited to 'indra/test/CMakeLists.txt')
-rw-r--r--indra/test/CMakeLists.txt37
1 files changed, 7 insertions, 30 deletions
diff --git a/indra/test/CMakeLists.txt b/indra/test/CMakeLists.txt
index 6f01a1336f..dc37066e52 100644
--- a/indra/test/CMakeLists.txt
+++ b/indra/test/CMakeLists.txt
@@ -4,7 +4,6 @@ project (test)
include(00-Common)
include(LLCommon)
-#include(LLDatabase)
include(LLInventory)
include(LLMath)
include(LLMessage)
@@ -74,12 +73,6 @@ if (NOT WINDOWS)
)
endif (NOT WINDOWS)
-#if (NOT DARWIN)
-# list(APPEND test_SOURCE_FILES
-# lldatabase_tut.cpp
-# )
-#endif (NOT DARWIN)
-
set_source_files_properties(${test_HEADER_FILES}
PROPERTIES HEADER_FILE_ONLY TRUE)
@@ -98,7 +91,6 @@ target_link_libraries(test
${LLCOMMON_LIBRARIES}
${EXPAT_LIBRARIES}
${GOOGLEMOCK_LIBRARIES}
-# ${APRICONV_LIBRARIES}
${PTHREAD_LIBRARY}
${WINDOWS_LIBRARIES}
${BOOST_PROGRAM_OPTIONS_LIBRARY}
@@ -135,25 +127,10 @@ ADD_CUSTOM_COMMAND(
set(test_results ${CMAKE_CURRENT_BINARY_DIR}/cpp_tests_ok.txt)
-if (EXISTS /etc/debian_version_FAIL)
- # The Python tests have all kinds of wacky non-portable assumptions
- # built in.
-
- add_custom_command(
- OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/py_tests_ok.txt
- COMMAND ${PYTHON_EXECUTABLE}
- ARGS
- ${CMAKE_CURRENT_SOURCE_DIR}/test.py
- --mode=static
- --output=${CMAKE_CURRENT_BINARY_DIR}/py_test_results.txt
- --touch=${CMAKE_CURRENT_BINARY_DIR}/py_tests_ok.txt
- --mode=static
- DEPENDS test.py
- WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
- COMMENT "Python unit tests"
- )
-
- list(APPEND test_results ${CMAKE_CURRENT_BINARY_DIR}/py_tests_ok.txt)
-endif (EXISTS /etc/debian_version_FAIL)
-
-add_custom_target(tests_ok ALL DEPENDS ${test_results})
+# This should cause the test executable to be built, but not
+# run if LL_TESTS is disabled. This will hopefully keep the
+# tests up to date with any code changes changes even if
+# developers choose to disable LL_TESTS.
+if (LL_TESTS)
+ add_custom_target(tests_ok ALL DEPENDS ${test_results})
+endif (LL_TESTS) \ No newline at end of file