summaryrefslogtreecommitdiff
path: root/indra/newview/CMakeLists.txt
diff options
context:
space:
mode:
authorGlenn Glazer <coyot@lindenlab.com>2016-05-23 12:08:59 -0700
committerGlenn Glazer <coyot@lindenlab.com>2016-05-23 12:08:59 -0700
commit9c28c06f1da98ba42d4d5546a2b2cdb7b042c13e (patch)
treec34fe4623405cef12d70b52b6a8ca08dab4579d0 /indra/newview/CMakeLists.txt
parent8c458778717666c7be7c6e0f0b19f28deb54b50f (diff)
backout 354346 / e63c00cf654a and 354347 / e4bfe3ee05a6
Diffstat (limited to 'indra/newview/CMakeLists.txt')
-rwxr-xr-xindra/newview/CMakeLists.txt13
1 files changed, 5 insertions, 8 deletions
diff --git a/indra/newview/CMakeLists.txt b/indra/newview/CMakeLists.txt
index 334a21a12e..4412b06d38 100755
--- a/indra/newview/CMakeLists.txt
+++ b/indra/newview/CMakeLists.txt
@@ -1310,6 +1310,11 @@ source_group("CMake Rules" FILES ViewerInstall.cmake)
# the viewer_version.txt file created here is for passing to viewer_manifest and autobuild
# the summary.json file is created for the benefit of the TeamCity builds, where
# it is used to provide descriptive information to the build results page
+add_custom_target(generate_viewer_version ALL
+ COMMAND printf '${VIEWER_SHORT_VERSION}.${VIEWER_VERSION_REVISION}' > ${CMAKE_CURRENT_BINARY_DIR}/viewer_version.txt
+ COMMENT Generating viewer_version.txt for manifest processing
+ )
+
set_source_files_properties(
llversioninfo.cpp tests/llversioninfo_test.cpp
@@ -1318,14 +1323,6 @@ set_source_files_properties(
COMPILE_DEFINITIONS "${VIEWER_CHANNEL_VERSION_DEFINES}" # see BuildVersion.cmake
)
-# the viewer_version.txt file created here is for passing to viewer_manifest and autobuild
-# the summary.json file is created for the benefit of the TeamCity builds, where
-# it is used to provide descriptive information to the build results page
-add_custom_target(generate_viewer_version ALL
- COMMAND printf '${VIEWER_SHORT_VERSION}.${VIEWER_VERSION_REVISION}' > ${CMAKE_CURRENT_BINARY_DIR}/viewer_version.txt
- COMMENT Generating viewer_version.txt for manifest processing
- )
-
if (DARWIN)
LIST(APPEND viewer_SOURCE_FILES llappviewermacosx.cpp)
LIST(APPEND viewer_SOURCE_FILES llappviewermacosx-objc.mm)