summaryrefslogtreecommitdiff
path: root/indra/newview/CMakeLists.txt
diff options
context:
space:
mode:
authorbrad kittenbrink <brad@lindenlab.com>2010-11-08 17:12:43 -0800
committerbrad kittenbrink <brad@lindenlab.com>2010-11-08 17:12:43 -0800
commit8cce8827e01dab6bfcd3e94e56b6041f8f487c76 (patch)
treeea9771dd6cc350128e7d10d62f878e773f82badc /indra/newview/CMakeLists.txt
parentf459524d817e9084f8a037cfe0768d05ee34edbb (diff)
Fix for breakpad symbol files failing to be generated on linux.
Diffstat (limited to 'indra/newview/CMakeLists.txt')
-rw-r--r--indra/newview/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/indra/newview/CMakeLists.txt b/indra/newview/CMakeLists.txt
index ff099710f1..a9d1fd9064 100644
--- a/indra/newview/CMakeLists.txt
+++ b/indra/newview/CMakeLists.txt
@@ -1837,13 +1837,13 @@ if (PACKAGE)
set(VIEWER_COPY_MANIFEST copy_l_viewer_manifest)
endif (LINUX)
- if(CMAKE_CONFIGURATION_TYPES)
+ if(CMAKE_CFG_INTDIR STREQUAL ".")
+ set(LLBUILD_CONFIG ${CMAKE_BUILD_TYPE})
+ else(CMAKE_CFG_INTDIR STREQUAL ".")
# set LLBUILD_CONFIG to be a shell variable evaluated at build time
# reflecting the configuration we are currently building.
set(LLBUILD_CONFIG ${CMAKE_CFG_INTDIR})
- else(CMAKE_CONFIGURATION_TYPES)
- set(LLBUILD_CONFIG ${CMAKE_BUILD_TYPE})
- endif(CMAKE_CONFIGURATION_TYPES)
+ endif(CMAKE_CFG_INTDIR STREQUAL ".")
add_custom_command(OUTPUT "${VIEWER_SYMBOL_FILE}"
COMMAND "${PYTHON_EXECUTABLE}"
ARGS