summaryrefslogtreecommitdiff
path: root/indra/newview/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrey Lihatskiy <alihatskiy@productengine.com>2020-07-22 14:41:19 +0300
committerAndrey Lihatskiy <alihatskiy@productengine.com>2020-07-22 14:41:19 +0300
commit7d4b1c014c9900af47005a529df50ece14249326 (patch)
treeb942868ac94a1cc4dc528420720dcade417f71d0 /indra/newview/CMakeLists.txt
parent358b65198a8d17067eddc1bb02d6363000b3699b (diff)
SL-13082 Declare macOS SDK version to be 10.12 instead of 10.15
Diffstat (limited to 'indra/newview/CMakeLists.txt')
-rw-r--r--indra/newview/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/indra/newview/CMakeLists.txt b/indra/newview/CMakeLists.txt
index 0d204fd716..a17bf088cd 100644
--- a/indra/newview/CMakeLists.txt
+++ b/indra/newview/CMakeLists.txt
@@ -1944,6 +1944,10 @@ elseif (DARWIN)
set_target_properties(${VIEWER_BINARY_NAME}
PROPERTIES
LINK_FLAGS_RELEASE "${LINK_FLAGS_RELEASE} -Xlinker -dead_strip -Xlinker -map -Xlinker ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_BINARY_NAME}.MAP"
+ # Force the SDK version in the linked executable to be 10.12. This will fool
+ # macOS into using the pre-Mojave display system, avoiding the blurry display that
+ # otherwise occurs when upscaling the viewer to Retina resolution levels.
+ LINK_FLAGS_RELEASE "${LINK_FLAGS_RELEASE} -Xlinker -platform_version -Xlinker macos -Xlinker ${CMAKE_OSX_DEPLOYMENT_TARGET} -Xlinker 10.12"
)
else (WINDOWS)
# Linux