summaryrefslogtreecommitdiff
path: root/indra/newview/CMakeLists.txt
diff options
context:
space:
mode:
authorOz Linden <oz@lindenlab.com>2012-08-22 11:12:55 -0400
committerOz Linden <oz@lindenlab.com>2012-08-22 11:12:55 -0400
commit5c4babf0fd718bae28f5b293280b5a99a0b35e0c (patch)
tree5524529c362b68a501bdf112aa03c74a1ed3a882 /indra/newview/CMakeLists.txt
parente4b553075e5e7cb725e219008d147298b24626bb (diff)
parent0e4fa75e6441cdb6dac8b9463ce9c3ff3a0a6596 (diff)
merge changes for DRTVWR-201
Diffstat (limited to 'indra/newview/CMakeLists.txt')
-rw-r--r--indra/newview/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/indra/newview/CMakeLists.txt b/indra/newview/CMakeLists.txt
index 753dbd7438..3cd03f8641 100644
--- a/indra/newview/CMakeLists.txt
+++ b/indra/newview/CMakeLists.txt
@@ -45,7 +45,10 @@ include(VisualLeakDetector)
include(GLOD)
include(CMakeCopyIfDifferent)
-add_subdirectory(${LLPHYSICSEXTENSIONS_SRC_DIR} llphysicsextensions)
+if (NOT HAVOK_TPV)
+ # When using HAVOK_TPV, the library is precompiled, so no need for this
+ add_subdirectory(${LLPHYSICSEXTENSIONS_SRC_DIR} llphysicsextensions)
+endif (NOT HAVOK_TPV)
include_directories(
${DBUSGLIB_INCLUDE_DIRS}