summaryrefslogtreecommitdiff
path: root/indra/newview/CMakeLists.txt
diff options
context:
space:
mode:
authorMonty Brandenberg <monty@lindenlab.com>2012-04-26 11:35:07 -0400
committerMonty Brandenberg <monty@lindenlab.com>2012-04-26 11:35:07 -0400
commit438a6431e418eac5a3a4e00f7adfe379994869d7 (patch)
treed8182def4e51da3ef8473c26220da047012710a7 /indra/newview/CMakeLists.txt
parenta54e9c379550f7901404990ea7fddb99c0188048 (diff)
Bring llcorehttp into the compile and link phases. Windows looks okay though it's a dead library so far.
Diffstat (limited to 'indra/newview/CMakeLists.txt')
-rw-r--r--indra/newview/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/indra/newview/CMakeLists.txt b/indra/newview/CMakeLists.txt
index f85b943c70..fc9d89aea0 100644
--- a/indra/newview/CMakeLists.txt
+++ b/indra/newview/CMakeLists.txt
@@ -18,6 +18,7 @@ include(LLAudio)
include(LLCharacter)
include(LLCommon)
include(LLConvexDecomposition)
+include(LLCoreHttp)
include(LLImage)
include(LLImageJ2COJ)
include(LLInventory)
@@ -52,6 +53,7 @@ include_directories(
${LLCHARACTER_INCLUDE_DIRS}
${LLCOMMON_INCLUDE_DIRS}
${LLCONVEXDECOMP_INCLUDE_DIRS}
+ ${LLCOREHTTP_INCLUDE_DIRS}
${FMOD_INCLUDE_DIR}
${LLIMAGE_INCLUDE_DIRS}
${LLKDU_INCLUDE_DIRS}
@@ -1747,6 +1749,7 @@ target_link_libraries(${VIEWER_BINARY_NAME}
${LLXUIXML_LIBRARIES}
${LSCRIPT_LIBRARIES}
${LLMATH_LIBRARIES}
+ ${LLCOREHTTP_LIBRARIES}
${LLCOMMON_LIBRARIES}
${NDOF_LIBRARY}
${viewer_LIBRARIES}