summaryrefslogtreecommitdiff
path: root/indra/newview/CMakeLists.txt
diff options
context:
space:
mode:
authorErik Kundiman <erik@megapahit.org>2023-07-29 14:35:02 +0800
committerErik Kundiman <erik@megapahit.org>2023-07-29 20:47:11 +0800
commit061eb674576157b72be23c9bc8c9d3ab905d280f (patch)
treecdc52b59f37274deeed95e38854a9799c5053e1b /indra/newview/CMakeLists.txt
parentc2e755287eee1e9c9af4f918b20a4b2fa5f361f7 (diff)
So we don't get errors from uninitialised vars
when compiling newview using GCC.
Diffstat (limited to 'indra/newview/CMakeLists.txt')
-rw-r--r--indra/newview/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/indra/newview/CMakeLists.txt b/indra/newview/CMakeLists.txt
index d6c8adfeab..1dbaa7437c 100644
--- a/indra/newview/CMakeLists.txt
+++ b/indra/newview/CMakeLists.txt
@@ -1936,6 +1936,12 @@ if (CMAKE_CXX_COMPILER_ID MATCHES "Clang")
set_source_files_properties(llappviewerlinux.cpp PROPERTIES
COMPILE_FLAGS -Wno-dangling-gsl
)
+elseif (CMAKE_CXX_COMPILER_ID MATCHES "GNU")
+ set_source_files_properties(
+ llface.cpp
+ llhttpretrypolicy.cpp
+ llpanelface.cpp
+ PROPERTIES COMPILE_FLAGS -Wno-maybe-uninitialized)
endif ()
if (LINUX)