summaryrefslogtreecommitdiff
path: root/indra/newview/CMakeLists.txt
diff options
context:
space:
mode:
authorOz Linden <oz@lindenlab.com>2011-08-09 13:47:19 -0400
committerOz Linden <oz@lindenlab.com>2011-08-09 13:47:19 -0400
commitc7b6a25728cd360348d1c3da5ace0971767206a4 (patch)
tree32197f15361538ab6ea4b8c540e18b0bfec6d4b6 /indra/newview/CMakeLists.txt
parent608403a8466a44a5aa46c6cae4a7a65ac4bf0084 (diff)
parentf8a2b67649416267cf86d4ff4568e59cdbaaa5c7 (diff)
merge late beta fixes for storm-1060
Diffstat (limited to 'indra/newview/CMakeLists.txt')
-rw-r--r--indra/newview/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/indra/newview/CMakeLists.txt b/indra/newview/CMakeLists.txt
index 86fbc248b0..7e1d46f0e8 100644
--- a/indra/newview/CMakeLists.txt
+++ b/indra/newview/CMakeLists.txt
@@ -1253,10 +1253,13 @@ if (WINDOWS)
endif(USE_PRECOMPILED_HEADERS)
# Replace the icons with the appropriate ones for the channel
+ # ('test' is the default)
set(ICON_PATH "test")
string(TOLOWER ${VIEWER_CHANNEL} channel_lower)
- if(channel_lower MATCHES "^(release|beta|development)")
+ if(channel_lower MATCHES "^(release|development)")
set(ICON_PATH ${channel_lower})
+ elseif(channel_lower MATCHES "^(beta.*)")
+ set(ICON_PATH "beta")
elseif(channel_lower MATCHES "^(project.*)")
set(ICON_PATH "project")
endif()