summaryrefslogtreecommitdiff
path: root/indra/newview/CMakeLists.txt
diff options
context:
space:
mode:
authorNicky <nicky.dasmijn@gmail.com>2022-04-06 20:25:49 +0200
committerNicky <nicky.dasmijn@gmail.com>2022-04-06 20:25:49 +0200
commit5f7c74fa2e796c04915b6da5e7db013a94c00e2d (patch)
tree1385bce7278714ee875623d591880dfa921d0942 /indra/newview/CMakeLists.txt
parentbed0b80374c3acfc584587a9b0bc02f8bf899876 (diff)
Create and use sdl::sdl target
Diffstat (limited to 'indra/newview/CMakeLists.txt')
-rw-r--r--indra/newview/CMakeLists.txt13
1 files changed, 0 insertions, 13 deletions
diff --git a/indra/newview/CMakeLists.txt b/indra/newview/CMakeLists.txt
index 9168941014..eccc082454 100644
--- a/indra/newview/CMakeLists.txt
+++ b/indra/newview/CMakeLists.txt
@@ -1715,17 +1715,6 @@ add_executable(${VIEWER_BINARY_NAME}
${viewer_SOURCE_FILES}
)
-if (SDL_FOUND)
- set_property(TARGET ${VIEWER_BINARY_NAME}
- PROPERTY COMPILE_DEFINITIONS LL_SDL=1
- )
-endif (SDL_FOUND)
-
-if (USE_BUGSPLAT)
- set_property(TARGET ${VIEWER_BINARY_NAME}
- PROPERTY COMPILE_DEFINITIONS "${BUGSPLAT_DEFINE}")
-endif (USE_BUGSPLAT)
-
# add package files
file(GLOB EVENT_HOST_SCRIPT_GLOB_LIST
${CMAKE_CURRENT_SOURCE_DIR}/../viewer_components/*.py)
@@ -1989,10 +1978,8 @@ target_link_libraries(${VIEWER_BINARY_NAME}
llcorehttp
llcommon
${viewer_LIBRARIES}
- ${FMODWRAPPER_LIBRARY} # must come after LLAudio
glod::glod
ndof::ndof
- ${SDL_LIBRARY}
${SMARTHEAP_LIBRARY}
${UI_LIBRARIES}
${WINDOWS_LIBRARIES}