summaryrefslogtreecommitdiff
path: root/indra/newview/CMakeLists.txt
diff options
context:
space:
mode:
authorNat Goodspeed <nat@lindenlab.com>2013-01-09 20:39:06 -0500
committerNat Goodspeed <nat@lindenlab.com>2013-01-09 20:39:06 -0500
commit34f231cc66bc746228fe367712447058d76757b3 (patch)
tree637f72962ef8f7ea36a6fee28455ec93ce2aefb5 /indra/newview/CMakeLists.txt
parentbf55755262244c7c36df781d2e093b4109f6ecbf (diff)
MAINT-1481: remove linux-updater; move logic to Linux update_install
Now that the viewer's own background updater logic is responsible for downloading a new installer, the only functionality we still use in linux-updater that couldn't be expressed more simply in bash is the UI. But since most Linux distros capable of running SL at all have zenity, and all will have xmessage, we can handle even the UI part. Add xmenity wrapper script so update_install doesn't have to care which is present, and make the bash script that used to launch linux-updater do the real work.
Diffstat (limited to 'indra/newview/CMakeLists.txt')
-rw-r--r--indra/newview/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/indra/newview/CMakeLists.txt b/indra/newview/CMakeLists.txt
index 0197ac794f..22960a2d0d 100644
--- a/indra/newview/CMakeLists.txt
+++ b/indra/newview/CMakeLists.txt
@@ -1865,7 +1865,6 @@ if (LINUX)
set(COPY_INPUT_DEPENDENCIES
${VIEWER_BINARY_NAME}
linux-crash-logger
- linux-updater
SLPlugin
media_plugin_webkit
media_plugin_gstreamer010