summaryrefslogtreecommitdiff
path: root/indra/newview/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreyL ProductEngine <alihatskiy@productengine.com>2019-10-09 19:32:19 +0300
committerAndreyL ProductEngine <alihatskiy@productengine.com>2019-10-09 19:32:19 +0300
commit12baf7587822bd6cd15885c45e973d0b7f9dceb4 (patch)
tree27ff68e9808f4b448bdb3b98da2c576f1dc4aa28 /indra/newview/CMakeLists.txt
parent7829b4d3f46ff21d1d932b06f4721760ebbde014 (diff)
parentfe490d52b45679edf5740fa46fc3c76d608bfc95 (diff)
Downstream merge from lindenlab/viewer-manul
Diffstat (limited to 'indra/newview/CMakeLists.txt')
-rw-r--r--indra/newview/CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/indra/newview/CMakeLists.txt b/indra/newview/CMakeLists.txt
index 95a916d7cb..6089162190 100644
--- a/indra/newview/CMakeLists.txt
+++ b/indra/newview/CMakeLists.txt
@@ -1381,8 +1381,12 @@ if (DARWIN)
PROPERTIES
COMPILE_DEFINITIONS "${VIEWER_CHANNEL_VERSION_DEFINES}"
# BugsplatMac is a module, imported with @import. That language feature
- # demands these switches.
- COMPILE_FLAGS "-fmodules -fcxx-modules"
+ # demands these -f switches.
+ # Xcode 10.2 requires that Objective-C++ headers declare nullability of
+ # pointer variables. As of 2019-06-26, the BugsplatMac version we're using
+ # does not yet do so in its own header files. This -W flag prevents fatal
+ # warnings.
+ COMPILE_FLAGS "-fmodules -fcxx-modules -Wno-nullability-completeness"
)
find_library(AGL_LIBRARY AGL)