summaryrefslogtreecommitdiff
path: root/indra/newview/CMakeLists.txt
diff options
context:
space:
mode:
authorNicky Dasmijn <nicky.dasmijn@phoenixviewer.com>2020-05-19 19:17:32 +0200
committerNat Goodspeed <nat@lindenlab.com>2020-05-20 10:46:57 -0400
commite29ba3bbdaf70127944389d3b4910d47dcf02aff (patch)
treefb35c227fc524e3fd6e168e9c4c2bf00d30b20af /indra/newview/CMakeLists.txt
parent68bfa4538f5c8229e43ead6617c3675aa64d12f5 (diff)
Remove more traces of find_library to search for DirectX and instead
rely on the SDK setup. Remove old dinput8 import library as it is not needed
Diffstat (limited to 'indra/newview/CMakeLists.txt')
-rw-r--r--indra/newview/CMakeLists.txt10
1 files changed, 1 insertions, 9 deletions
diff --git a/indra/newview/CMakeLists.txt b/indra/newview/CMakeLists.txt
index 6f21ec93cc..460b2e6985 100644
--- a/indra/newview/CMakeLists.txt
+++ b/indra/newview/CMakeLists.txt
@@ -1582,20 +1582,12 @@ if (WINDOWS)
list(APPEND viewer_SOURCE_FILES ${viewer_RESOURCE_FILES})
endif (NOT USESYSTEMLIBS)
- find_library(DINPUT_LIBRARY dinput8 ${DIRECTX_LIBRARY_DIR})
- find_library(DXGUID_LIBRARY dxguid ${DIRECTX_LIBRARY_DIR})
- mark_as_advanced(
- DINPUT_LIBRARY
- DXGUID_LIBRARY
- )
-
# see EXP-1765 - theory is opengl32.lib needs to be included before gdi32.lib (windows libs)
set(viewer_LIBRARIES
opengl32
${WINDOWS_LIBRARIES}
comdlg32
- ${DINPUT_LIBRARY}
- ${DXGUID_LIBRARY}
+ dxguid
kernel32
odbc32
odbccp32