summaryrefslogtreecommitdiff
path: root/indra/newview/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreyL ProductEngine <alihatskiy@productengine.com>2018-02-15 20:03:59 +0200
committerAndreyL ProductEngine <alihatskiy@productengine.com>2018-02-15 20:03:59 +0200
commitd0811218381cfa9d201d7b72532e19d98bda250a (patch)
tree65d3c325feeac71171813d3302bd1c4517b22cb2 /indra/newview/CMakeLists.txt
parentcc30a9e2f5b9410dcdf323d3ecdd3f6f1e2985db (diff)
parent5510b589b136d354ce2975c45f41ccc7e66e9d21 (diff)
Merged in lindenlab/viewer-release
Diffstat (limited to 'indra/newview/CMakeLists.txt')
-rw-r--r--indra/newview/CMakeLists.txt16
1 files changed, 14 insertions, 2 deletions
diff --git a/indra/newview/CMakeLists.txt b/indra/newview/CMakeLists.txt
index 1594711197..502f76980a 100644
--- a/indra/newview/CMakeLists.txt
+++ b/indra/newview/CMakeLists.txt
@@ -18,6 +18,7 @@ include(JsonCpp)
include(LLAppearance)
include(LLBase)
include(LLAudio)
+include(LLCA)
include(LLCharacter)
include(LLCommon)
include(LLCoreHttp)
@@ -1625,6 +1626,7 @@ set(viewer_APPSETTINGS_FILES
app_settings/viewerart.xml
${CMAKE_SOURCE_DIR}/../etc/message.xml
${CMAKE_SOURCE_DIR}/../scripts/messages/message_template.msg
+ ${AUTOBUILD_INSTALL_DIR}/ca-bundle.crt
packages-info.txt
)
@@ -1749,8 +1751,6 @@ if (WINDOWS)
${SHARED_LIB_STAGING_DIR}/RelWithDebInfo/libhunspell.dll
${SHARED_LIB_STAGING_DIR}/Debug/libhunspell.dll
${SHARED_LIB_STAGING_DIR}/${CMAKE_CFG_INTDIR}/SLVoice.exe
- ${SHARED_LIB_STAGING_DIR}/${CMAKE_CFG_INTDIR}/vivoxsdk.dll
- ${SHARED_LIB_STAGING_DIR}/${CMAKE_CFG_INTDIR}/ortp.dll
${SHARED_LIB_STAGING_DIR}/${CMAKE_CFG_INTDIR}/libsndfile-1.dll
${SHARED_LIB_STAGING_DIR}/${CMAKE_CFG_INTDIR}/vivoxoal.dll
${SHARED_LIB_STAGING_DIR}/${CMAKE_CFG_INTDIR}/ca-bundle.crt
@@ -1771,6 +1771,18 @@ if (WINDOWS)
windows-crash-logger
)
+ if (ADDRESS_SIZE EQUAL 64)
+ list(APPEND COPY_INPUT_DEPENDENCIES
+ ${SHARED_LIB_STAGING_DIR}/${CMAKE_CFG_INTDIR}/vivoxsdk_x64.dll
+ ${SHARED_LIB_STAGING_DIR}/${CMAKE_CFG_INTDIR}/ortp_x64.dll
+ )
+ else (ADDRESS_SIZE EQUAL 64)
+ list(APPEND COPY_INPUT_DEPENDENCIES
+ ${SHARED_LIB_STAGING_DIR}/${CMAKE_CFG_INTDIR}/vivoxsdk.dll
+ ${SHARED_LIB_STAGING_DIR}/${CMAKE_CFG_INTDIR}/ortp.dll
+ )
+ endif (ADDRESS_SIZE EQUAL 64)
+
if (FMODEX)
list(APPEND COPY_INPUT_DEPENDENCIES
${SHARED_LIB_STAGING_DIR}/Release/fmodex.dll