summaryrefslogtreecommitdiff
path: root/indra/newview/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad Linden <brad@lindenlab.com>2023-03-01 09:51:08 -0800
committerBrad Linden <brad@lindenlab.com>2023-03-13 10:27:22 -0700
commit804c207dcc07b9ae39922a3475de7e9a513f3e16 (patch)
tree0efec73a95760f887f691e8a6e36edf6a0e86b78 /indra/newview/CMakeLists.txt
parente5d80b600012ab4250eb226af150fbec5e485ee3 (diff)
Partial solution for SL-18458 Materials override cache not working and related SL-18684/SL-19206/SL-19173
Diffstat (limited to 'indra/newview/CMakeLists.txt')
-rw-r--r--indra/newview/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/indra/newview/CMakeLists.txt b/indra/newview/CMakeLists.txt
index 1588f16f07..3271de72c9 100644
--- a/indra/newview/CMakeLists.txt
+++ b/indra/newview/CMakeLists.txt
@@ -2383,6 +2383,7 @@ if (LL_TESTS)
# llremoteparcelrequest.cpp
llviewerhelputil.cpp
llversioninfo.cpp
+ llvocache.cpp
llworldmap.cpp
llworldmipmap.cpp
)
@@ -2396,6 +2397,13 @@ if (LL_TESTS)
#llviewertexturelist.cpp
)
+ set_source_files_properties(
+ llvocache.cpp
+ PROPERTIES
+ LL_TEST_ADDITIONAL_SOURCE_FILES
+ ../llmessage/lldatapacker.cpp
+ )
+
set(test_libs
${LLCOMMON_LIBRARIES}
${JSONCPP_LIBRARIES}