summaryrefslogtreecommitdiff
path: root/indra/newview/CMakeLists.txt
diff options
context:
space:
mode:
authorNat Goodspeed <nat@lindenlab.com>2022-06-09 17:04:26 -0400
committerNat Goodspeed <nat@lindenlab.com>2022-06-09 17:04:26 -0400
commit64209ddeeafd944f82da6f13a6e790f9b542b3ff (patch)
tree2fbbd95bc513209be558b2e92aee0a9058a1bee4 /indra/newview/CMakeLists.txt
parent1e28b8d992e6f24f85fde5c86bf9824bf7c7d277 (diff)
SL-17483: Add integration test for CommonControl
and for LLViewerControlListener, to which it talks. Fix glitches detected by the tests.
Diffstat (limited to 'indra/newview/CMakeLists.txt')
-rw-r--r--indra/newview/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/indra/newview/CMakeLists.txt b/indra/newview/CMakeLists.txt
index c253eca94e..f13ce85495 100644
--- a/indra/newview/CMakeLists.txt
+++ b/indra/newview/CMakeLists.txt
@@ -2506,6 +2506,19 @@ if (LL_TESTS)
"${test_libs}"
)
+ set(llviewercontrollistener_test_sources
+ llviewercontrollistener.cpp
+ ../llxml/llcontrol.cpp
+ ../llxml/llxmltree.cpp
+ ../llxml/llxmlparser.cpp
+ ../llcommon/commoncontrol.cpp
+ )
+
+ LL_ADD_INTEGRATION_TEST(llviewercontrollistener
+ "${llviewercontrollistener_test_sources}"
+ "${test_libs}"
+ )
+
LL_ADD_INTEGRATION_TEST(llviewernetwork
llviewernetwork.cpp
"${test_libs}"