summaryrefslogtreecommitdiff
path: root/indra/newview/CMakeLists.txt
diff options
context:
space:
mode:
authorJJ Linden <jj@lindenlab.com>2014-10-13 12:46:55 -0700
committerJJ Linden <jj@lindenlab.com>2014-10-13 12:46:55 -0700
commit5cb5c267caed96b23e1c6c7b8d3c04aaefe84c6a (patch)
treee238dd104c9a478c7b753713ce1cfc30f835340d /indra/newview/CMakeLists.txt
parent4fb1bae807a5dd8a342946b8f23d2a7a5aa5d36a (diff)
fixes for cmake warnings about policy changes. could not fully test these changes
Diffstat (limited to 'indra/newview/CMakeLists.txt')
-rwxr-xr-xindra/newview/CMakeLists.txt14
1 files changed, 7 insertions, 7 deletions
diff --git a/indra/newview/CMakeLists.txt b/indra/newview/CMakeLists.txt
index e8f4144e70..9899dac439 100755
--- a/indra/newview/CMakeLists.txt
+++ b/indra/newview/CMakeLists.txt
@@ -2039,10 +2039,10 @@ if (LINUX)
add_custom_target(copy_l_viewer_manifest ALL DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/.${product}.copy_touched)
if (PACKAGE)
- add_custom_target(package ALL DEPENDS ${product}.tar.bz2)
+ add_custom_target(llpackage ALL DEPENDS ${product}.tar.bz2)
# Make sure we don't run two instances of viewer_manifest.py at the same time.
- add_dependencies(package copy_l_viewer_manifest)
- check_message_template(package)
+ add_dependencies(llpackage copy_l_viewer_manifest)
+ check_message_template(llpackage)
endif (PACKAGE)
endif (LINUX)
@@ -2104,11 +2104,11 @@ if (DARWIN)
endif (ENABLE_SIGNING)
if (PACKAGE)
- add_custom_target(package ALL DEPENDS ${VIEWER_BINARY_NAME})
- add_dependencies(package generate_viewer_version)
+ add_custom_target(llpackage ALL DEPENDS ${VIEWER_BINARY_NAME})
+ add_dependencies(llpackage generate_viewer_version)
add_custom_command(
- TARGET package POST_BUILD
+ TARGET llpackage POST_BUILD
COMMAND ${PYTHON_EXECUTABLE}
ARGS
${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py
@@ -2190,7 +2190,7 @@ if (PACKAGE)
add_custom_target(generate_breakpad_symbols DEPENDS "${VIEWER_SYMBOL_FILE}")
add_dependencies(generate_breakpad_symbols "${VIEWER_BINARY_NAME}" "${VIEWER_COPY_MANIFEST}")
- add_dependencies(package generate_breakpad_symbols)
+ add_dependencies(llpackage generate_breakpad_symbols)
endif(RELEASE_CRASH_REPORTING OR NON_RELEASE_CRASH_REPORTING)
endif (PACKAGE)