summaryrefslogtreecommitdiff
path: root/indra/newview/CMakeLists.txt
diff options
context:
space:
mode:
authorErik Kundiman <erik@megapahit.org>2023-10-14 07:32:03 +0800
committerErik Kundiman <erik@megapahit.org>2023-10-14 07:32:03 +0800
commit46273f40e8116a06bf7460903a1451e88ca2fad4 (patch)
tree9b3fdc6b3884c23dc993168cbd991998f28e5fb7 /indra/newview/CMakeLists.txt
parent82391adeb81656b6b23559c52bf4a3db2c932673 (diff)
Not build libvlc on macOS for now
At runtime it hasn't worked anyway. And now we can get an ARM build without having to build libvlc for ARM first.
Diffstat (limited to 'indra/newview/CMakeLists.txt')
-rw-r--r--indra/newview/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/indra/newview/CMakeLists.txt b/indra/newview/CMakeLists.txt
index 8b1ba4daa5..8c1124214c 100644
--- a/indra/newview/CMakeLists.txt
+++ b/indra/newview/CMakeLists.txt
@@ -2120,8 +2120,10 @@ if (DARWIN)
if (USE_AUTOBUILD_3P OR USE_CONAN)
add_dependencies(${VIEWER_BINARY_NAME} SLPlugin media_plugin_libvlc media_plugin_cef)
- else ()
+ elseif (NOT DARWIN)
add_dependencies(${VIEWER_BINARY_NAME} SLPlugin media_plugin_libvlc)
+ else ()
+ add_dependencies(${VIEWER_BINARY_NAME} SLPlugin)
endif ()
if (ENABLE_SIGNING)