summaryrefslogtreecommitdiff
path: root/indra/newview/CMakeLists.txt
diff options
context:
space:
mode:
authorErik Kundiman <erik@megapahit.org>2024-07-01 13:31:14 +0800
committerErik Kundiman <erik@megapahit.org>2024-07-01 13:31:14 +0800
commit29d68ecb229ecb19e6d0da4cf5fbd8e3bbdde2cf (patch)
treee60f85379679aa2b07c8a17a1fcd4954572149c2 /indra/newview/CMakeLists.txt
parenta38b53cc5f456593e8ca21c5d5e20542c1723525 (diff)
parent1478ec8e9c50eba8b3a64fb9c2fc54a3a328510b (diff)
Merge branch 'main' into maint-b
Diffstat (limited to 'indra/newview/CMakeLists.txt')
-rw-r--r--indra/newview/CMakeLists.txt13
1 files changed, 6 insertions, 7 deletions
diff --git a/indra/newview/CMakeLists.txt b/indra/newview/CMakeLists.txt
index 5d52d4b202..d282557efc 100644
--- a/indra/newview/CMakeLists.txt
+++ b/indra/newview/CMakeLists.txt
@@ -1421,15 +1421,15 @@ set_source_files_properties(
)
if (DARWIN)
- if (NOT USESYSTEMLIBS)
+# if (NOT USESYSTEMLIBS)
LIST(APPEND viewer_SOURCE_FILES llappviewermacosx.cpp)
LIST(APPEND viewer_SOURCE_FILES llappviewermacosx-objc.mm)
LIST(APPEND viewer_SOURCE_FILES llappviewermacosx-objc.h)
- endif (NOT USESYSTEMLIBS)
+# endif (NOT USESYSTEMLIBS)
LIST(APPEND viewer_SOURCE_FILES llfilepicker_mac.mm)
LIST(APPEND viewer_HEADER_FILES llfilepicker_mac.h)
- if (NOT USESYSTEMLIBS)
+# if (NOT USESYSTEMLIBS)
# This should be compiled with the viewer.
LIST(APPEND viewer_SOURCE_FILES llappdelegate-objc.mm)
set_source_files_properties(
@@ -1444,7 +1444,7 @@ if (DARWIN)
# warnings.
COMPILE_FLAGS "-fmodules -fcxx-modules -Wno-nullability-completeness"
)
- endif (NOT USESYSTEMLIBS)
+# endif (NOT USESYSTEMLIBS)
# Add resource files to the project.
set(viewer_RESOURCE_FILES
@@ -1464,7 +1464,7 @@ if (DARWIN)
list(APPEND viewer_SOURCE_FILES ${viewer_RESOURCE_FILES})
endif (DARWIN)
-if (USESYSTEMLIBS)
+if (USESYSTEMLIBS AND NOT DARWIN)
LIST(APPEND viewer_SOURCE_FILES llappviewerlinux.cpp)
set_source_files_properties(
llappviewerlinux.cpp
@@ -1475,7 +1475,7 @@ if (USESYSTEMLIBS)
SET(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -Wl,--as-needed")
endif ()
-endif (USESYSTEMLIBS)
+endif (USESYSTEMLIBS AND NOT DARWIN)
if (WINDOWS)
list(APPEND viewer_SOURCE_FILES
@@ -1960,7 +1960,6 @@ target_link_libraries(${VIEWER_BINARY_NAME}
${LLPHYSICSEXTENSIONS_LIBRARIES}
ll::bugsplat
ll::tracy
- ll::fontconfig
)
if (ENABLE_MEDIA_PLUGINS)