summaryrefslogtreecommitdiff
path: root/indra/newview/CMakeLists.txt
diff options
context:
space:
mode:
authorDave Simmons <simon@lindenlab.com>2009-03-20 20:00:47 +0000
committerDave Simmons <simon@lindenlab.com>2009-03-20 20:00:47 +0000
commit24b26d71ee01211aa796b8061b66ec06a133e4ce (patch)
tree96bffcd019c933ad3ebbfd5f096968108b22aab5 /indra/newview/CMakeLists.txt
parent5dfd435872e36445dcc82f99443dfc5a7ee0805a (diff)
svn merge -r113004:115000 svn+ssh://svn.lindenlab.com/svn/linden/branches/server/server-1.26
Merge latest 1.26 into trunk
Diffstat (limited to 'indra/newview/CMakeLists.txt')
-rw-r--r--indra/newview/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/indra/newview/CMakeLists.txt b/indra/newview/CMakeLists.txt
index 1ca1b4f915..ac05a7dbd7 100644
--- a/indra/newview/CMakeLists.txt
+++ b/indra/newview/CMakeLists.txt
@@ -11,6 +11,7 @@ include(ELFIO)
include(FMOD)
include(OPENAL)
include(FindOpenGL)
+include(LLAddBuildTest)
include(LLAudio)
include(LLCharacter)
include(LLCommon)
@@ -64,6 +65,7 @@ include_directories(
set(viewer_SOURCE_FILES
llagent.cpp
+ llagentaccess.cpp
llagentdata.cpp
llagentlanguage.cpp
llagentpilot.cpp
@@ -466,6 +468,7 @@ set(viewer_HEADER_FILES
ViewerInstall.cmake
llagent.h
+ llagentaccess.h
llagentdata.h
llagentlanguage.h
llagentpilot.h
@@ -1566,3 +1569,5 @@ endif (DARWIN)
if (INSTALL)
include(${CMAKE_CURRENT_SOURCE_DIR}/ViewerInstall.cmake)
endif (INSTALL)
+
+ADD_VIEWER_BUILD_TEST(llagentaccess viewer)