summaryrefslogtreecommitdiff
path: root/indra/newview/CMakeLists.txt
diff options
context:
space:
mode:
authorErik Kundiman <erik@megapahit.org>2023-08-26 15:46:12 +0800
committerErik Kundiman <erik@megapahit.org>2023-08-26 15:46:12 +0800
commit00be9e00107c51a35c04f64fe917c559b8325564 (patch)
treee7aebc8ad6e398da3a5e475a1983368749eeafb0 /indra/newview/CMakeLists.txt
parenta09352872b2f1a9db452d9cc313088abd5fb75c0 (diff)
CPack for packaging (when PACKAGE set to on)
Since we could use the dynamic versioning from the configuration phase of CMake, the inclusion is put in BuildVersion.cmake. Other CPACK variables are usually static so can be set when running cmake. CPack somehow doesn't pick up the DESTINATION values in ViewerInstall (slplugin & libvlc too) from UnixInstall, so they're they're partially hardcoded again there.
Diffstat (limited to 'indra/newview/CMakeLists.txt')
-rw-r--r--indra/newview/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/indra/newview/CMakeLists.txt b/indra/newview/CMakeLists.txt
index 226f9a3bda..b5c88cfca1 100644
--- a/indra/newview/CMakeLists.txt
+++ b/indra/newview/CMakeLists.txt
@@ -1955,6 +1955,8 @@ elseif (CMAKE_CXX_COMPILER_ID MATCHES "GNU")
-Wno-stringop-truncation)
endif ()
+if (NOT USESYSTEMLIBS)
+
if (LINUX)
set(product SecondLife-${ARCH}-${VIEWER_SHORT_VERSION}.${VIEWER_VERSION_REVISION})
@@ -2141,6 +2143,8 @@ if (DARWIN)
endif (PACKAGE)
endif (DARWIN)
+endif (NOT USESYSTEMLIBS)
+
if (INSTALL)
include(${CMAKE_CURRENT_SOURCE_DIR}/ViewerInstall.cmake)
endif (INSTALL)