summaryrefslogtreecommitdiff
path: root/indra/newview/CMakeLists.txt
diff options
context:
space:
mode:
authorSeth ProductEngine <slitovchuk@productengine.com>2011-09-21 19:28:16 +0300
committerSeth ProductEngine <slitovchuk@productengine.com>2011-09-21 19:28:16 +0300
commit00ba099a9e23103900399803ffc375873fbfe4a3 (patch)
treeca53d73dd1d6b342257ec0103a03a3ddb864f44e /indra/newview/CMakeLists.txt
parent5baf0de6a396b120aba4e2351ed5bff70f2562ef (diff)
EXP-1221 FIXED Added a floater container class that provides an interface for all former Side Tray panels.
The container implements a unified behavior similar to Side Tray tabs for all floaters: - LLSD params are passed to the main panel (root panel containing other child panels) upon opening the floater via LLFloaterReg, - LLSD params can be passed to one of the child panels using LLFloaterSidePanelContainer::openChildPanel() - transient floaters (e.g. IM windows) should not hide when the container floater is clicked, so that it's possible to drag an inventory item from My Inventory floater to a docked IM window.
Diffstat (limited to 'indra/newview/CMakeLists.txt')
-rw-r--r--indra/newview/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/indra/newview/CMakeLists.txt b/indra/newview/CMakeLists.txt
index 11b19ca4fe..4001cd3975 100644
--- a/indra/newview/CMakeLists.txt
+++ b/indra/newview/CMakeLists.txt
@@ -228,6 +228,7 @@ set(viewer_SOURCE_FILES
llfloatersearch.cpp
llfloatersellland.cpp
llfloatersettingsdebug.cpp
+ llfloatersidepanelcontainer.cpp
llfloatersidetraytab.cpp
llfloatersnapshot.cpp
llfloatersounddevices.cpp
@@ -791,6 +792,7 @@ set(viewer_HEADER_FILES
llfloatersearch.h
llfloatersellland.h
llfloatersettingsdebug.h
+ llfloatersidepanelcontainer.h
llfloatersidetraytab.h
llfloatersnapshot.h
llfloatersounddevices.h