summaryrefslogtreecommitdiff
path: root/indra/media_plugins/webkit/CMakeLists.txt
diff options
context:
space:
mode:
authorTofu Linden <tofu.linden@lindenlab.com>2010-06-22 11:07:35 +0100
committerTofu Linden <tofu.linden@lindenlab.com>2010-06-22 11:07:35 +0100
commit7295e1ee034b3163b2f1c9f4aa11695beb7db8b0 (patch)
tree4512485cb15ea748554ca9e91b1afee710549893 /indra/media_plugins/webkit/CMakeLists.txt
parentb0791c3001f669a32abc4d4b40f4dc4f6f2bc912 (diff)
EXT-7889 PARTIAL Linux fails to load splash screen and side panel home tab.
Start to restore manual glib handling. Backed out changeset ff86a9f5b917
Diffstat (limited to 'indra/media_plugins/webkit/CMakeLists.txt')
-rw-r--r--indra/media_plugins/webkit/CMakeLists.txt11
1 files changed, 10 insertions, 1 deletions
diff --git a/indra/media_plugins/webkit/CMakeLists.txt b/indra/media_plugins/webkit/CMakeLists.txt
index 5bccd589d8..812760a116 100644
--- a/indra/media_plugins/webkit/CMakeLists.txt
+++ b/indra/media_plugins/webkit/CMakeLists.txt
@@ -9,6 +9,7 @@ include(LLPlugin)
include(LLMath)
include(LLRender)
include(LLWindow)
+include(UI)
include(Linking)
include(PluginAPI)
include(MediaPluginBase)
@@ -38,7 +39,7 @@ add_library(media_plugin_webkit
${media_plugin_webkit_SOURCE_FILES}
)
-target_link_libraries(media_plugin_webkit
+set(media_plugin_webkit_LINK_LIBRARIES
${LLPLUGIN_LIBRARIES}
${MEDIA_PLUGIN_BASE_LIBRARIES}
${LLCOMMON_LIBRARIES}
@@ -46,6 +47,14 @@ target_link_libraries(media_plugin_webkit
${PLUGIN_API_WINDOWS_LIBRARIES}
)
+if (LINUX)
+ list(APPEND media_plugin_webkit_LINK_LIBRARIES
+ ${UI_LIBRARIES} # for glib/GTK
+ )
+endif (LINUX)
+
+target_link_libraries(media_plugin_webkit ${media_plugin_webkit_LINK_LIBRARIES})
+
add_dependencies(media_plugin_webkit
${LLPLUGIN_LIBRARIES}
${MEDIA_PLUGIN_BASE_LIBRARIES}