summaryrefslogtreecommitdiff
path: root/indra/media_plugins/webkit/CMakeLists.txt
diff options
context:
space:
mode:
authorOz Linden <oz@lindenlab.com>2010-10-11 08:59:19 -0400
committerOz Linden <oz@lindenlab.com>2010-10-11 08:59:19 -0400
commite2e70577f90d9551f4afe637bfd486654d778e5e (patch)
tree831de0c3fa62bc84d7e67f8c5041976efb60d84d /indra/media_plugins/webkit/CMakeLists.txt
parentecbc00351aed97cfe2f87267789732ff00c2333b (diff)
parentbb74487c859acccb8f88002630606419761136e4 (diff)
merged fix for STORM-222
Diffstat (limited to 'indra/media_plugins/webkit/CMakeLists.txt')
-rw-r--r--indra/media_plugins/webkit/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/indra/media_plugins/webkit/CMakeLists.txt b/indra/media_plugins/webkit/CMakeLists.txt
index 57478ddf27..05f1236606 100644
--- a/indra/media_plugins/webkit/CMakeLists.txt
+++ b/indra/media_plugins/webkit/CMakeLists.txt
@@ -32,6 +32,14 @@ include_directories(
### media_plugin_webkit
+if(NOT WORD_SIZE EQUAL 32)
+ if(WINDOWS)
+ add_definitions(/FIXED:NO)
+ else(WINDOWS) # not windows therefore gcc LINUX and DARWIN
+ add_definitions(-fPIC)
+ endif(WINDOWS)
+endif(NOT WORD_SIZE EQUAL 32)
+
set(media_plugin_webkit_SOURCE_FILES
media_plugin_webkit.cpp
)