summaryrefslogtreecommitdiff
path: root/indra/media_plugins/webkit/CMakeLists.txt
diff options
context:
space:
mode:
authorMonroe Linden <monroe@lindenlab.com>2010-04-13 10:10:58 -0700
committerMonroe Linden <monroe@lindenlab.com>2010-04-13 10:10:58 -0700
commit157bc3071da89b15f1393475e906e7301698cc8a (patch)
tree51ce16b1b38104483decf5af675a3738182f6afb /indra/media_plugins/webkit/CMakeLists.txt
parent82b399ed1bf4cd63e27adf298096107b245a29be (diff)
Initial implementation of mac_volume_catcher.cpp.
Diffstat (limited to 'indra/media_plugins/webkit/CMakeLists.txt')
-rw-r--r--indra/media_plugins/webkit/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/indra/media_plugins/webkit/CMakeLists.txt b/indra/media_plugins/webkit/CMakeLists.txt
index c3a3f8e2b2..4f183cddeb 100644
--- a/indra/media_plugins/webkit/CMakeLists.txt
+++ b/indra/media_plugins/webkit/CMakeLists.txt
@@ -51,6 +51,14 @@ if (LINUX AND PULSEAUDIO)
list(APPEND media_plugin_webkit_LINK_LIBRARIES
${UI_LIBRARIES} # for glib/GTK
)
+elseif (DARWIN)
+ list(APPEND media_plugin_webkit_SOURCE_FILES mac_volume_catcher.cpp)
+ find_library(CORESERVICES_LIBRARY CoreServices)
+ find_library(AUDIOUNIT_LIBRARY AudioUnit)
+ list(APPEND media_plugin_webkit_LINK_LIBRARIES
+ ${CORESERVICES_LIBRARY} # for Component Manager calls
+ ${AUDIOUNIT_LIBRARY} # for AudioUnit calls
+ )
else (LINUX AND PULSEAUDIO)
# All other platforms use the dummy volume catcher for now.
list(APPEND media_plugin_webkit_SOURCE_FILES dummy_volume_catcher.cpp)